Jailbroken iphone 3GS 4.0.2 stuck in iTunes screen with USB cable

Discussion in 'iPhone Tips, Help and Troubleshooting' started by born2njoy, Jun 13, 2011.

  1. born2njoy macrumors newbie

    Joined:
    Jun 13, 2011
    #1
    Hey Gems

    I have an iphone 3GS running 4.0.2 OS jailbroken with jailbreakme.com. A week back when I restarted my phone, it got stuck up in itunes screen showing USB cable. I read through many articles and tried all methods and softwares such as Irecovery, RecBoot, TinyUmbrella, but nothing worked. I thought of restoring it to 4.0.2 using the original IPSW file and that too didn't work as I got 3194 connection error. I am afraid to use the standard restore as it will update the OS to 4.3.3 and don't know if this version can be successfully unlocked ?.
    Could you please guide me on what options I have now ?. Thanks a lot.
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    Do you know if you have the SHSH saved for 4.0.2? If you do, then edit your host files and then you can restore to 4.0.2

    Or you can use PwnageTool (Mac) or Sn0wbreeze (Windows) to create a custom 4.3.3 ipsw and preserve your baseband to unlock.
     
  3. born2njoy thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #3
    Thanks mate. I don't hv my SHSH saved, so I'll go for an upgrade to 4.3.3. BTW, when I tried to downgrade to 4.0.1/3.1.3 using standard ipsw, I got 3194 error even after adding the two servers in Host file. Would I get the same error when I upgrade to 4.3.3 as well ?
     
  4. born2njoy thread starter macrumors newbie

    Joined:
    Jun 13, 2011
    #4
    Thanks a lot for your input. I followed your advise and upgraded my OS to 4.3.3 using custom IPSW file preserving the baseband and unlocked it through Ultrasnow. I got out of recovery loop and able to use my phone after a week of struggles. But ever after this restore, my 3GS battery drains too fast and is getting overheated. Is it because of the custom IPSW file or because of the OS 4.3.3 ?. I disabled notifications, location services, mails, 3G and multitasking, but still it does not hold the charge for more than 4 hrs. Any ideas ?.
     

Share This Page