Jailbroken & Unlocked iPhone 3GS having trouble connecting to 3G network

Discussion in 'Jailbreaks and iOS Hacks' started by you silly GOOSE, Feb 23, 2011.

  1. you silly GOOSE macrumors member

    Joined:
    Feb 23, 2011
    #1
    Hey all,

    I recently jailbroke and unlocked my 3GS (while also changing to the iPad baseband).

    Using it now, I am having trouble with connecting to the 3G network (ie: updating/checking emails, using the facebook app, twitter, etc...). The WiFi works fine.

    I'm also a Rogers customer.

    Is this a known issue following the jailbreak/unlock with the iPad baseband? If so is there anything I can do?

    Thanks in advance.
     
  2. you silly GOOSE thread starter macrumors member

    Joined:
    Feb 23, 2011
    #2
    Interesting...

    I decided to play around with things to see if I can find out what the problem is.

    I ended up restoring without installing Cydia and it turns out that now my phone is working well. I can do everything above pretty fast. However, I do not have Cydia.

    Is there something then I did not do when I had Cydia installed? Is it known to interfere with the phone?

    Lastly, my GPS is working fine (with the iPad baseband).
     
  3. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #3
    How did you restore? I take it you used pwnagetool? Sounds like you forgot to include cydia in the pwnagetool generated firmware.
     
  4. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #4
    I have had success installing to stock firmware on 6.15.00 on both iPhone 3G and 3GS.

    Congratulations on not ruining your GPS! If you're on stock, just jb with GP. Unlock again with Ultrasn0w and you're set!
     
  5. you silly GOOSE thread starter macrumors member

    Joined:
    Feb 23, 2011
    #5
    I used redsn0w and simply unchecked the line where it said "install Cydia". I dont know what changed, but my phone is getting internet access now

    Yeah i guess i got lucky with the GPS. But i seem to be having problems with push notifications like others have had. I searched around and there haven't been many resolutions for that.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Did you activate the iphone prior to JB with an official sim?
    If you hactivated it you will have Push issues.
     
  7. you silly GOOSE thread starter macrumors member

    Joined:
    Feb 23, 2011
    #7
    Yes, the phone was activated before it was JB.
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Weird, mine works fine.
    Is it all Push notifications or from a few apps not coming in?
     
  9. you silly GOOSE thread starter macrumors member

    Joined:
    Feb 23, 2011
    #9
    Actually, now that you mention it, it's only a few apps (unless im mistaken here).

    my e-mails are arriving fine, as well as things like updates from the appstore app.

    facebook however isn't arriving as well as my sports apps (espn & thescore)
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    Dont get me started about facebook, I havent received anything pushed from that app in months:D
    And some other apps have push issues that drive me nuts.
    Not sure if its the particular apps servers or apples causing this but it sucks.
    Not much you can do about it though.
     
  11. you silly GOOSE thread starter macrumors member

    Joined:
    Feb 23, 2011
    #11
    eh no worries. i can survive without fb notifications and i already impulsively check scores manually haha.

    thanks for the help!
     

Share This Page