Japanese input / Kotoeri Problems

Discussion in 'Mac Basics and Help' started by eleven7, May 25, 2009.

  1. eleven7 macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #1
    I having two problems with kotoeri that I'm hoping someone can help me out with. The first I might have seen someone ask before on here but can't find it using the search so apologies if that is the case.

    Firstly, can you set kotoeri to work independently for each application? On windows for example, you can be using the Japanese input in Word, then once you switch to another application, that program's input preference comes into play. Basically, the language input system changes according to whatever application is in focus.

    In OS X, as far as I can tell, kotoeri works universally, so if I'm typing away in Japanese in Word then switch over quickly to Adium, the input still is in Japanese. A lot of the time when I'm busy and want to send a quick IM, and get back to my work, this can be quite frustrating for me, and for the person who receives a message in Japanese that makes no sense. e.g - "いぇs" instead of "yes". Is there a way to make kotoeri be application independent?


    Secondly, when working in MS Word, I am typing in English in say 12pt calabri, then I switch to Japanese, input one word then change back to English, the font doesn't return back to 12pt calabri, it changes back to English but stays as some gross ancient font. I'm guessing this might be more of a problem with MS Word but does anyone know how to change this? Or knows whether this happens in the iWork suite? I'd consider switching if it doesn't. It might not sound like much of a problem but it's annoying as hell.

    Any help would be much appreciated.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Interestingly, the per-application input method behavior you're describing used to be the default. In 10.4, I believe, Apple added a switch to toggle between that and the current behavior. In 10.5 the current behavior became the default and the switch was removed entirely.

    I've personally always preferred the current behavior, but I don't know why they removed the toggle. (Ok, I do--Apple always tries to reduce complexity--but given how integral it is to multilingual users I don't think they should have.) I know of no way of bringing the old behavior back, but you might try this if you don't have a Japanese keyboard with the "input switch" key beside the spacebar: Set command-space to switch between the two recent inputs, and set Spotlight to activate on some other key sequence (command-option-space or something). That way you don't need to remove your hands from the keyboard to switch character sets, so long as you get in the habit of reflexively doing so manually.

    As for the second question, yes, I'm pretty sure this is just Word's abysmal support for multiple languages. I haven't tested Pages specifically, but it should work exactly the same as Textedit, Mail, and other Apple apps. And, since those do what you want--switch to the previous English font after dropping back to English input--I assume Pages would as well.

    Given how many people complain about the lack of a character set switch behavior (my wife was an old-style fan as well), somebody ought to start a petition to get them to bring it back in 10.6.
     
  3. eleven7 thread starter macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #3
    Thanks for the detailed reply Makosuke :) I was hoping that wasn't the case but I'm still pretty new to mac so it may just take a bit of getting used to. I'll keep at it and see how I get on.

    As with the other problem, I think I'll go download the iWork trial now and see how I get on.

    Thanks again for you help.
     
  4. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #4
    I'd almost forgotten, but I just realized someone here recommended InputSwitcher to someone with the same question as you:

    http://limechat.net/inputswitcher/

    I've never used it, but it apparently locks each app into a default language. It's free, so it might be worth at least an experiment to see if it feels better with the way you work.
     

Share This Page