Japanese Keyboard Problems.. Kotoeri / Romaji Problems

Discussion in 'MacBook Pro' started by Jelsoft, Oct 20, 2010.

  1. Jelsoft macrumors member

    Joined:
    Apr 10, 2010
    #1
    I've noticed that sometimes, whilst I'm typing away using romaji mode, my punctuation keys suddenly get remapped to what I'm assuming is the american, british or whatever layout.

    For instance, brackets/parentheses which are usually assigned to shift+8 or 9 become shift+9 or 0

    I usually remedy the problem by tapping the kana and romaji input buttons till it sorts itself out. If that doesn't work, I turn on and switch to US or British, and then turn it off again and switch back to Romaji.

    Can anyone explain why this might be happening? I think it's happening across all apps, but it's most noticeable when i'm switching between Japanese and Romaji input in Word.

    Thanks guys!
     
  2. JiggityJules macrumors newbie

    Joined:
    Jul 23, 2008
    #2
    1) Go to the icon where you toggle between input methods on the top right of the screen.
    2) Select anything except for "US" and more options should appear.
    3) Then select "Kotoeri Preferences" and use the pop up to toggle the option to "convert on punctuation mark." It's on the bottom left.

    Hope that fixes it. I just came across this option right after I read your post trying to figure out my own shortcut issues.
     
  3. palpatine macrumors 68040

    Joined:
    May 3, 2011
    #3
    That is weird. I have never had that problem.

    I guess I would suggest you confirm your settings. I have US Extended, Kotoeri (Hiragana), and Chinese-Traditional (Pinyin) selected in my 言語とテキスト. I also have the radio button for すべての書類で同じ物を使用 checked there.

    I was wondering what you meant by "romaji mode." Presumably, you mean you are still typing with the Japanese keyboard setting, but in romaji (英字) mode. I think the reason I am not encountering the same problem is that I type English with the US Extended. I do not type English with the Japanese keyboard setting. I would suggest de-selecting everything but the hiragana for the Japanese (in your keyboard settings), and using the command + space bar to switch between English and Japanese instead of staying in Japanese all the time for both languages.

    By the way, Word recently got an update (SP1) that completely destroyed my ability to type Japanese. It is documented on their site (and the fix can be found on the MacRumor forums as well), but of course Microsoft didn't widely publicize the fact that they screwed up Word for the Japanese language users, so it took me a few hours and much frustration to reach a solution. Although your problem may be totally unrelated, it is good to keep in mind the possibility (I would have never thought about it) that updates could impact functionality.

    I haven't fooled around with my Kotoeri preferences, as far as I know, and I cannot seem to find them, so I cannot tell you what my settings are there.

    Also, I have a US keyboard installed. I don't know if the Japanese keyboard would make a difference, but I could imagine a keyboard mapping problem being the potential culprit as well.
     
  4. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #4
    What computer are you using, MBP bought in Japanese with a JIS keyboard?
    What OS version? What version of Office? MS Word?
    see this thread for related info:
    http://forums.macrumors.com/showthread.php?t=1170200
    I have ATOK 10 installed as well, on a JIS 2009 keyboard MBP and now no issues with Japanese input using Word 14.1.2 (latest update). Word is not perfect by any means, but at least you can type in romaji mode to display either hiragana or katakana. I have English set as the main language in System Preferences, with only Japanese also enabled. Kotoeri is disabled, as I like the dictionaries in ATOK much more than Kotoeri, which is a real "baka."
     
  5. palpatine macrumors 68040

    Joined:
    May 3, 2011
    #5
    hi david. sorry to hijack the thread, but i am interested in atok. kotoeri really angers me sometimes. it can't figure out basic modern words, and premodern words are hopeless. i never had so many problems with microsoft (ime?). i get around it ok, but i'd sure like something less baka. any links you can suggest?
     
  6. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #6
    http://www.atok.com/try/
    30 day trial - can buy it if you like it.
    The dictionaries ATOK uses are very good, and the interface can be customized.
    You must have Japanese selected as the first (top) language in the International Preference pane to install it (works fine if English is on top after the installation).
    Using Japanese is much easier if you have a Japanese keyboard but it is not required.
     
  7. palpatine macrumors 68040

    Joined:
    May 3, 2011
    #7
    Thanks David. It's awful expensive, but I'll give it a try and see how it does!
     

Share This Page