Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

WolfSnap

macrumors 65816
Original poster
Sep 18, 2012
1,076
919
SoCal
I installed Java 1.8, but, I have a program that apparently requires Java 1.6 -- my Drobo Dashboard (iSCSI support).

I'd like to avoid, if I can, installing the old Lion version of Java that Apple made. Anyone know how to trick the program into using the newer 1.8?
 

poiihy

macrumors 68020
Aug 22, 2014
2,301
62
Most Java app bundles (.app) use Java 6 because they were compiled with Apple's Jar Bundler. To make a bundle work with latest java you must use Oracle's bundler. .jar files will use latest version though. You can work around this by using the .jar verison of the app. Go in the contents of the app and you may find a jar file somewhere in resources; try to launch it.

I had a lot of this baloney with Minecraft. Howver Minecraft, and a lot of Java software out there, are made for Java 6 and work best with it.

Read the RTF in the zip attached. It is a website I downloaded a while ago but don't have original link so I had to copy and paste into RTF
 

Attachments

  • Java 6 Java 8 bla bla bla.zip
    18.7 KB · Views: 108

ebika

macrumors 6502a
Nov 17, 2008
816
756
Chicago
That's exact opposite of what OP wants. OP already has this and wants to get rid of it. xP

Yeah, but there's no reason not to install it. Java 8 will still be the default, and 1.6 will work with the legacy apps.
 

ebika

macrumors 6502a
Nov 17, 2008
816
756
Chicago
OP already has it.

OP said s/he was looking to avoid installing it, so probably not. Yosemite removes 1.6, so it's easy to just put it back and move on. And yeah, I know I'm not answering OP's request, I'm suggesting just installing 1.6. :)
 

WolfSnap

macrumors 65816
Original poster
Sep 18, 2012
1,076
919
SoCal
OP said s/he was looking to avoid installing it, so probably not. Yosemite removes 1.6, so it's easy to just put it back and move on. And yeah, I know I'm not answering OP's request, I'm suggesting just installing 1.6. :)

I was hoping there was a way to avoid re-installing it. 1.6 isn't exactly cutting edge and bug free.......

Oh well, if there's really no way, then, I'll just add it, and remove it later, but, that kinda sucks :(
 

ebika

macrumors 6502a
Nov 17, 2008
816
756
Chicago
I was hoping there was a way to avoid re-installing it. 1.6 isn't exactly cutting edge and bug free.......

Oh well, if there's really no way, then, I'll just add it, and remove it later, but, that kinda sucks :(

poiihy gave a way to do it without installing 1.6.
 

WolfSnap

macrumors 65816
Original poster
Sep 18, 2012
1,076
919
SoCal
poiihy gave a way to do it without installing 1.6.

Missed that. Taking a look at it now.. But, since its a kext, I'm pretty sure I can't hack it too much without breaking it.

----------

Most Java app bundles (.app) use Java 6 because they were compiled with Apple's Jar Bundler. To make a bundle work with latest java you must use Oracle's bundler. .jar files will use latest version though. You can work around this by using the .jar verison of the app. Go in the contents of the app and you may find a jar file somewhere in resources; try to launch it.

I had a lot of this baloney with Minecraft. Howver Minecraft, and a lot of Java software out there, are made for Java 6 and work best with it.

Read the RTF in the zip attached. It is a website I downloaded a while ago but don't have original link so I had to copy and paste into RTF

Thanks! I'll check this out in more detail tomorrow.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.