Java application doesn't work!

Discussion in 'macOS' started by gabrielcik17, Sep 3, 2009.

  1. gabrielcik17 macrumors newbie

    Joined:
    Sep 3, 2009
    #1
    Hello,

    I need to call Ukraine by using a special java application (VOIP) which allow to call for free the mobile subscribers of this provider (Life).

    The problem is that this java application works perfectly in Windows but doesn't work at all on Leopard. (the same also in Ubuntu)

    This is the application:

    http://www.life.com.ua/index.php?area=mylife&lng=en&page=3-500
    (u should press "launch web-client")

    The error i get is the following:

    "Unable to launch application"

    "Error: Unsigned application requesting unrestricted access to system
    Unsigned resource:
    http://www.life.com.ua/freeworld/webstart/jmf-all/jmf.jar"

    Do u have any idea how to solve this problem? (in windows it works without any issue)

    Thank you!
     
  2. fm2503 macrumors member

    fm2503

    Joined:
    May 5, 2009
    Location:
    North Wales
    #2
    Probably a JRE version issue. Try going into Java Prefs and dragging the 32 bit version of java to the top. Note that only Java6 is present now, so if the app needs java 5 then you are stuck.
     
  3. rpp3po macrumors regular

    Joined:
    Aug 16, 2003
    Location:
    Germany
    #3
    I think Windows is behaving incorrectly here. You are using WebStart which starts programs directly from a simple URL. Java requires this code to be digitally signed as a security measure. Obviously this code is either not signed by a trusted party or not signed at all. Preventing remote code to be executed on you local machine with full privileges (open ports, send & receive data) is correct behavior. Either download the jar and execute it locally or install the website's certificates into you certificate store.
     
  4. gabrielcik17 thread starter macrumors newbie

    Joined:
    Sep 3, 2009
    #4
    Thank you for the support!

    I have already J2 SE 5.0 32 as first choice... but doesn't help...

    I believe the problem is more about certificate than the java itself...

    How can i make it works even if there is not a valid certificate?

    (long ago i tried to copy the certificate form Windows (there the application works and it is possible even to see the certificate in the control panel) to Ubuntu... but same result...

    I asked directly to this company but no answer...

    Thank you!
     
  5. Sparky9292 macrumors 6502a

    Joined:
    Aug 1, 2004
    #5
    In some of the Java forums, we are getting reports of incompatibilities of Java applications. Java programs and applets that ran fine in 10.5.x are having problems in SL.
     

Share This Page