Java compatibility?

Discussion in 'Mac Programming' started by Aranince, May 24, 2008.

  1. Aranince macrumors 65816

    Joined:
    Apr 18, 2007
    Location:
    California
    #1
    So I'm writing a Java applet, which currently runs perfectly fine in windows using Java 6 in FireFox, IE, and Safari. I tried to run the applet on a Mac in Safari and it wouldn't initialize, no errors in the console. I compiled it using the 1.6 JDK, the mac is running 1.5 Java. The macbook is running Leopard 1.5.2. Why won't my applet run? JDK 6 not compatible with 1.5?
     
  2. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #2
    Well if you are using features from 1.6 then it obviously won't work on 1.5.
     
  3. Aranince thread starter macrumors 65816

    Joined:
    Apr 18, 2007
    Location:
    California
    #3
    Ia there a way to find out if/what I'm using that's a 1.6 feature? Because AFAIK, I'm not.
     
  4. cube macrumors G5

    Joined:
    May 10, 2004
  5. Aranince thread starter macrumors 65816

    Joined:
    Apr 18, 2007
    Location:
    California
    #5
    Cool, I'll try that out. Thanks.

    Edit: It worked!
     

Share This Page