Java, Flash Player and PDF's don't work

Discussion in 'Mac OS X Lion (10.7)' started by pozzydrive, Dec 9, 2012.

  1. pozzydrive macrumors newbie

    Joined:
    Mar 3, 2011
    #1
    Hi all

    First off, please be advised, I am a total novice with regard to any computers, I have trawled the web for a fix, to no avail, or what has been provided as a fix, I just could not understand it.
    I have Lion OSX 10.7 installed on my iMac 27" computer. All of the items in the title above, used to work fine, even when I upgraded to LION OSX. I believe that using Onyx may have caused me the issues I am going to describe.

    - I've tried to download Java a number of times, each time a window opens telling me it is already installed, yet when I go into Library, there is no Java folder there, I have also unhidden all folders, or at least followed the instructions from others to do so.
    - The same goes for flash player, as for PDF's I cannot open a PDF online, yet can open a PDF on my desktop, however not all PDF's can be downloaded e.g. my energy bill, so cannot read it, just a bunch of gobbledygook.
    - I also tried using sudo commands (once again advice from various websites) to find java, among other things and find, that when it asks for my password as administrator, it will not allow me to enter any password or type anything for that matter.
    - The only reference to Java I can find is in the Library/Preferences folder (I tried to attach these files, not sure if its worked).

    As you can see a number of issues and I would be grateful for any help I can get.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    It sounds like you may have deleted some required system files. I would reinstall Lion over top your existing install to fix this. You won't lose your data, but backup first just to be safe.
     
  3. pozzydrive thread starter macrumors newbie

    Joined:
    Mar 3, 2011
    #3
    Thank you

    Weaselboy

    Thank you, will give it a try.

    Regards

    Pozzy
     

Share This Page