Java for 32-bit AND Leopard!?!

Discussion in 'Mac Apps and Mac App Store' started by quakerkat, Jul 7, 2008.

  1. quakerkat macrumors newbie

    Joined:
    Jul 7, 2008
    #1
    I am caught in a catch-22.

    I have a core duo (i.e. 32-bit) Intel iMac running Leopard.

    My Brother printer's firmware requires Java. It sends me to install the latest Java for mac:
    http://welcome.solutions.brother.co...dw_us_eu&type2=4&os=81&flang=4&dlid=dlf002792

    The Java versions here seem to require either 10.4 OR 10.5 and a 64-bit iMac:
    http://developer.apple.com/java/download/

    Even the ones that say "version 10.4.10 or later" refuse to be installed in Leopard. And the version for Leopard requires a 64-bit iMac (again, refuses to install).

    Any suggestions?

    Or, do I already HAVE some form of Java, running in my mac, and don't really need to go out and get it?

    (I should also mention I am the person who figures out techy stuff for my writer friends, but no programmer. So please be gentle. ;) )
     
  2. quakerkat thread starter macrumors newbie

    Joined:
    Jul 7, 2008
    #2
    Hmmm...

    Okay, I think I solved part of my question: I found the Java Preferences in the Utilities and so I've verified I have Java running already.

    Here's another question:

    the firmware requires Java 1.4.2 or later.

    Java Preferences offers me JSE 5.0 or JSE 1.4.2. Which is "later"? (I know bigger numbers = more recent, but there's something odd about choosing between 5 and 1.4.2).

    Thanks again.
     
  3. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #3
    Got all the latest Leopard updates?

    I downloaded it, and was able to run the .jar application no problem. I haven't any 3rd party Java utilities, just what comes with OS X.
     
  4. BlueJay macrumors newbie

    Joined:
    Jul 7, 2008
    Location:
    Colorado Springs
    #4
    Java SE 5.0 for 32 bit Macs

    Java SE 5.0 is the latest 32-bit Java for Macs.
     
  5. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #5
    Mac OS X comes with Java built in.
     
  6. quakerkat thread starter macrumors newbie

    Joined:
    Jul 7, 2008
    #6
    Ahhhh, finally

    Okay, I finally got it.

    Made sure Java 5 was selected in the Java Prefs.

    Made sure the wireless brother printer was awake and connected to the network (it kept going to sleep).

    And it finally worked.

    Thanks, all!
     

Share This Page