JAVA in Lion won't run even after install

Discussion in 'Mac OS X Lion (10.7)' started by twwilso, Jul 21, 2011.

  1. twwilso macrumors newbie

    Joined:
    Jul 23, 2007
    #1
    i installed lion yesterday and downloaded the java installer package. completed that, and then tried to run a java application in safari (my work uses live meeting so i need java to work). i get an error message. i tried reinstalling java again, still no luck. i did reload safari. i tried rebooting machine.

    i also went to a java website to use their "test" to see if java is installed, and i got an error there as well. i turned java logging on and this is what i got:

    java.lang.ClassNotFoundException: JavaVersionDisplayApplet.class
    at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:252)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:250)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:180)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:161)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:687)
    at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3046)
    at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1498)
    at java.lang.Thread.run(Thread.java:680)




    so it looks to me like some files are missing? i don't really know how to fix this. any ideas?

    thanks.
     
  2. tamasnet macrumors newbie

    Joined:
    Jul 22, 2011
    #2
    Same thing, bigger problem

    I've got the same problem, I think. Whenever I try to launch a Java-based application I get an OS X crash report which implies that java.lang.Class could not be loaded. So I tried creating an absolutely trivial "Hello World" test class and javac reports:

    tamas$ javac -cp . Test.java
    java.lang.ClassNotFoundException
    - klass: 'java/lang/ClassNotFoundException'
    Trace/BPT trap: 5

    Now one thing I did that might be a bit out of the ordinary is I manually installed a 1.5 JDK as well (similar to how I had it in 10.6), so I'm wondering if there's a shared JDK cache somewhere that's corrupted. I did try rebooting and also reinstalling the Java Update for Lion, but no joy.

    This sucks because if I can't resolve it by Sunday evening I'll have to revert to 10.6 until a solution is identified...
     
  3. tamasnet macrumors newbie

    Joined:
    Jul 22, 2011
    #3
    Different thing

    So upon further consideration I think my problem was different from the OP's. His/her stack trace clearly shows that the Java runtime and applet plugin classes were loaded and running, whereas in my case even the most basic runtime classes were missing.

    So for twwilso I suggest that the problem might be with the test page you were using rather than with the Lion Java install. I'm not sure which test page you used, but this one worked fine for me in the end.

    Back to my actual problem: after a bunch of different attempts to fix things I got desperate and tried a re-install of Lion (over top of my existing Lion installation). And that worked! So I am now able to run my Java-based apps as expected.

    I do still need JDK 1.5 support eventually but I am not going to repeat my install experiment until (a) I am happy that there are no further surprises in Lion and (b) I have a good backup image of my working Lion setup.
     
  4. Graig macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #4
    Goto Java preferences and check Enable java applet....... fixed mine I think and I did reinstall the down load from Apple first. I wonder what a good example would be to really test it. Java website said it was working fine
     
  5. Sirius OSX macrumors newbie

    Joined:
    Jul 25, 2011
    #5
    Live Meeting stuck on Java Loading

    I have the same issue. I've been researching since upgrading to Lion last week. My corporation uses Live Meeting on BPOS-D or now Microsoft hosted Office365-Dedicated.

    I can't confirm if Java 1.5 only is required or if 1.6 just didn't install correctly. I can't confirm that Java is working as Java.com doesn't really provide legitimate tests for Mac OSX. Apple Update doesn't identify any issues with Java.

    I have tried running in both Safari and Firefox 5.0.1. Should I uninstall everything Java?


    STOP THE PRESSES.... I FIGURED IT OUT!

    I did a number of things while writing this, but I think reading through this MS page/document clued me in.

    All I did was go to Java Preferences (under Utilities) and on the Advanced Tab, ensure that the last option on the list "Verify mixed security code (sandbox vs. trusted)" is set to "Enable - run with protections, no warnings". This is probably what was causing Java to hang before opening the session.

    I will comment that as I write this, I've been sitting in the Live Meeting Lobby and my MBAir's fans are kicking in. I have noticed that Java can heat things up a bit. Kind of annoying, but so glad to have this functionality again.
     
  6. twwilso thread starter macrumors newbie

    Joined:
    Jul 23, 2007
    #6
    that worked! well, partially. i can see other people's shared screens, but i can't share my screen due to some javahost thing still being powerpc.

    thank you very much for posting a reply and helping to get it working. all i need now is the ability to share my screen and then lion will be awesome!

    thanks again for your help.

    todd
     
  7. Sirius OSX macrumors newbie

    Joined:
    Jul 25, 2011
    #7
    Live Meeting Java Issue may still exist

    Glad it worked for you. Glad I'm not the only one out there. I admit I didn't test an actual meeting/presentation. I just joined an ongoing meeting's lobby. I will test with an actual meeting tomorrow and see if I can share my screen.

    I never even tested full functionality of presenting in OSX SL, and wasn't ever sure that would work.

    Fortunately I'm not too concerned about being able to share my screen. Although I'm sure it will come up, most associates would not want to see my OSX. I have a PC at my desk that I would use for most presentations.
     
  8. Sirius OSX macrumors newbie

    Joined:
    Jul 25, 2011
    #8
    Can't be presenter in Live Meeting on Lion

    You're right. I couldn't accept or function as a presenter. I appeared as though there was a Java plugin trying to load.

    If this functionality existed before, which I don't doubt that it did, I just didn't get a chance to try it, maybe this is a compatibility issue more than just a security problem like the previous.

    Let me know if you come across anything.
     
  9. tc60045 macrumors newbie

    Joined:
    Mar 31, 2006
    #9
    You guys saved my bacon -- thanks SO MUCH for posting that setting in Java Preferences. Karma smiles on you....
     
  10. jsgreen macrumors 6502

    Joined:
    Nov 27, 2007
    Location:
    NH
  11. twwilso thread starter macrumors newbie

    Joined:
    Jul 23, 2007
    #11
    has anyone figured out how to share your desktop in live meeting using lion yet? i'm going to have to go back to snow leopard if i don't get this resolved soon.

    thanks for any help.
     
  12. mavenel macrumors newbie

    Joined:
    Oct 25, 2011
    #12
    Can't be presenter in Live Meeting on Lion

    Still looking for a fix for the LiveMeeting issue on Lion. I cannot be presenter. Anyone have any luck with this? Tx.
     
  13. mattroberts66 macrumors newbie

    Joined:
    Nov 2, 2011
    #13
    Java applet won't open after OSX Lion upgrade

    Hope someone can help a non techie here. I have recently upgraded to Lion and Java applets don't load. I only use them for visiting one website, a chat room and I don't even get the coffee cup now. Where the applet appeared for choosing username and logging into chatroom used to be is now just a blank space. Very depressed! Anyone have any ideas? I have checked a few online help forums and all the Java is up-to-date and enabled, Java SE6. Thanks if anyone out there can help/advise.
     
  14. chrisd. macrumors newbie

    Joined:
    Nov 10, 2011
    #14
    I am having the same problem as mattroberts
    basically I think I know what the issue is. As stated on the Java website

    64 bit Java is not supported for webapps, use the 32 bit Java

    I have know about this issues for two years and it still persists. Simply put any website that launches a java applet from a web page only works with 32bit java

    So the question is How can I disable 64bit Java and only run 32 bit

    Here is the Java Console output I get when trying to access Cisco Any Connect VPN

    Thu Nov 10 12:28:06 PST 2011 ExecuteDownloader: ic=sa
    Exception in thread "Thread-13" java.lang.UnsatisfiedLinkError: /private/var/folders/jt/rgjwvzf53xn13c3hcqhf_fhh0000gn/T/20111110122806307jniverify.so: no suitable image found. Did find: /private/var/folders/jt/rgjwvzf53xn13c3hcqhf_fhh0000gn/T/20111110122806307jniverify.so: mach-o, but wrong architecture
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
     
  15. Madd the Sane macrumors 6502

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #15
    Wirelessly posted (Mozilla/5.0 (iPod; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    For web apps, you have to launch Safari in 32-bit mode. You can do this by clicking on Safari, going to File, then Get Info…, and clicking the box that says "Run in 32-bit mode."
     
  16. mattroberts66 macrumors newbie

    Joined:
    Nov 2, 2011
    #16
    There is no 'Get Info' option to run in 32 bit mode!

    :confused:
     
  17. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #17
    You don't see this checkbox?

    [​IMG]

    Remember, this is from the Finder, select the Safari application, and choose File -> Get Info (or hit Cmd-I).

    jW
     
  18. ATLiens2000 macrumors newbie

    Joined:
    Jan 26, 2012
    #18
    Sirius OSX: Thank you so much for finding that solution!

    For two weeks I couldn't figure this out.
     
  19. JMC2008 macrumors newbie

    Joined:
    Mar 21, 2009
    #19
    Awesome...!

    Why would this have to be this hard? Could there not be a pop up of some sort in the MacOS that would give you the solution on the selection of the "Advanced" options.

    This was a huge headache for me and it was not easy to find - well I never looked in the right place I guess.

    This was not the first time that I Googled it and had came up with nothing.

    Thanks to all !!!!
    :D


     
  20. nananamom macrumors newbie

    Joined:
    Feb 9, 2012
    #20
    doesn't work on two machines

    I have two machines, an iMac running Lion and a MBA running Snow Leopard. Both machines are up to date via Software Update and therefore both are running Java 1.6.0_29

    iMac: Java(TM) SE Runtime Environment (build 1.6.0_29-b11-402-11D50b)
    MBA: Java(TM) SE Runtime Environment (build 1.6.0_29-b11-402-10M3527)

    I have verified (on the iMac, it's not available on Snow Leopard) in Java Preferences that applets and JWS are enabled and I played around with different settings in "Verify mixed security code" (both "run with protections, no warnings" and "Disable", just to see if that was the problem) but still no joy.

    Neither of these basic test sites work for me, on either machine, neither in Safari nor in Chrome.
    http://www.java.com/en/download/testjava.jsp
    http://javatester.org/version.html

    I did also try starting Safari in 32-bit mode as suggested above, that didn't make a bit of difference and in fact it looked like it was still running the 64 bit version of Java, based on the console output (below). I tried reordering the 32 bit and 64 bit versions in Java Preferences, that made no difference. It wouldn't let me select ONLY the 32 bit version there.

    Java Plug-in 1.6.0_29
    Using JRE version 1.6.0_29-b11-402-11D50b Java HotSpot(TM) 64-Bit Server VM
    User home directory = /Users/usernameload: class testJava2_1/TestVMApplet.class not found.​

    I'm at a loss for what else to try but it is very frustrating not to be able to get Java to work in any browser on either of my machines. At this point I suspect it's an issue with Java since I'm dealing with two different OS versions, different browsers, etc. However it also looks like the Oracle Java 7 development version doesn't support plugins either so that's a non-starter.
    http://jdk7.java.net/macportpreview/releasenote.html

    I'd appreciate any help.
     

Share This Page