Java issue on Safari and Firefox

Discussion in 'macOS' started by Franciturci, Aug 16, 2010.

  1. Franciturci macrumors member

    Joined:
    Oct 7, 2009
    #1
    Hallo. I've been trying to load the following page containing some Java applets

    http://www.slu.edu/classes/maymk/banchoff/Grapher2D.html

    Safari and Firefox don't load any of the applets (I just get an "Error" message with no further detail) while Google Chrome has no problem loading the page and each of the applets.

    I wonder if Chrome has a special plugin for java (in chrome://plugins it says that it has a Java Plug-In 2 for NPAPI Browsers ) allowing it to make a workaround to a system wide problem in java for mac.

    I've also tried to get to the page with Windows Xp via Parallels and everything is smooth and fine. Several other java applets on other sites show the same problem.

    I'm running Mac OS X 10.6.4 with Java 1.6.0_20 installed.
     
  2. AppleCode macrumors regular

    AppleCode

    Joined:
    Jul 28, 2010
    #2
    I tried it ,it works for me and I have the same version of java, I would say maybe reinstall java or update safari or firefox. If updates are available.
     
  3. Franciturci thread starter macrumors member

    Joined:
    Oct 7, 2009
    #3
    I've reinstalled Java with the package downloade from the Apple site. The problem persists.

    I've tried to run Safari in 32bit mode with no result. I've tried to set java to 32 bit mode in Java Preferences, but when i lode the applets, it is still in 64 bit mode.

    Are you running Java in 32 bit mode maybe?
     
  4. Franciturci thread starter macrumors member

    Joined:
    Oct 7, 2009
    #4
    Finally, it is a 32 bit vs 64 bit problem : in Java Preferences I've set the following option to the Java Virtual Machine for applets:

    HTML:
    -d32

    Now both Firefox and Safari work with java applets.
     
  5. Franciturci thread starter macrumors member

    Joined:
    Oct 7, 2009
    #5
    Sad thing: the problem comes back with no apparent reason.
     
  6. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    The issue appears to be local to your system.
     
  7. philajoe macrumors newbie

    Joined:
    Jul 31, 2010
    Location:
    Philadelphia, PA
    #7
    Purchases via Safari and Firefox

    I could not purchase a piece of software from a third party vendor and could not purchase some equipment from Apple Store while using Safari latest version. I switched to Firefox and was able to make the purchases.

    Could this be a java problem?

    When I tried to make purchase from the third party vendor I got the following message as to why i could not proceed, "missing
    USERGROUPID field".:confused:
     

Share This Page