Java Launch Problem. Seeking Help!!!

Discussion in 'Mac Programming' started by TJNuge, Oct 12, 2009.

  1. TJNuge macrumors newbie

    Oct 12, 2009
    So I am trying to do some tablature editing.
    Essentially like Guitar Pro for Window, but I found this application called:
    Tux Guitar(Version 1.1)
    What I read about it and saw pictures of looked good enough so I downloaded it and when I try to launch the application nothing happens.
    I get that split second application launch animation, but nothing actually happens.
    So I pressed ctr+click to get the control menu and I clicked on "Show Package Contents"
    In that folder there is a READ ME txt file and a couple other txt files, I read the READ ME and it did say that it is normal to have launch problems, but the only conclusion they had was to make sure that your java runtime environment is at least 1.4
    But I don't feel like that is it because I have Snow Leopard and I even went to software update in the apple menu, but nothing showed up.
    In Package Contents there are a total of 3 .jar files.
    The one titled JuxGuitar.jar (which I assume is the program) when clicked on I get the message:" The Java JAR file “tuxguitar.jar” could not be launched. Check the Console for possible error messages."
    I've never really worked with much java stuff before so I don't know what its telling me exactly.
    So I tried manually starting up the tuxguitar.jar file (if that's how you would say it) . . . I went to System/Library/CoreServices/JarLauncher
    But nothing happened again.
    So of the other two remaining .jar files "swt.jar" doesn't launch when clicked. I don't know if it's supposed to, but I know an SWT is important to java stuff. When I click on the last .jar file "iText.jar" It RUNS!!!!
    I don't know if this is just some random mini application that the developer put in the TuxGuitar file or if it essential to the overall operation of this TuxGuitar app.
    Anyways . . . Does anyone know what I'm talking about?
    I'm I just an idiot making no sense?
    Can You Help Me? (I would really appreciate it.)

    Also maybe If you or someone you know could just recommend another guitar tablature editing application that's free as well then that could just replace my problem all together. :apple: Thanks :apple:
  2. askthedust macrumors regular


    Jan 17, 2003
  3. TJNuge thread starter macrumors newbie

    Oct 12, 2009
    I've been reading a forum that either the developers or techs that work for the developers of the application i'm trying to use, and it seemed like there was a problem with the SWT for the program, so you had to change it out with a updated modified one, then there was a plugin that didn't work with that new SWT so you just had to remove it, but then there were still error. So I had to change my default Java Application from 64-Bit to 32-Bit. And I almost got it working, but I found another application that gets the job done, and i won't have to worry about any problems.

    Thanks for the link. It helped.:apple:
  4. chown33 macrumors 604

    Aug 9, 2009
    Sailing beyond the sunset
    The pre-built download is pretty old. It won't launch on Leopard, either, without changing a global Java preference. The app really needs to be rebuilt and adapted to what's changed in Mac OS X since Java 1.4 was current.

    To make it run as-is on Snow Leopard (or Leopard), you must run Java Preferences, which is located in /Applications/Utilities on Snow Leopard, or in /Applications/Utilities/Java on Leopard.

    In Java (which may take several seconds to launch), with the General tab selected, in the lower section labeled Java Applications, drag a 32-bit Java version to the top of the list. Quit. Double-click and it should launch.

    The problem is should not be relying on a user's preference. It should be self-configured to only run a 32-bit JVM.

    The other problem is that some other app might need the user preference set to a 64-bit JVM. That, of course, is a problem with that app. No app should rely on a user's preference to that extent.

    edit: Oh, I see you found the 32-bit JVM for Applications preference.

Share This Page