Java Noob here... XCode 3 giving me a hard time.

Discussion in 'Mac Programming' started by Zwhaler, Nov 10, 2007.

  1. Zwhaler macrumors 604


    Jun 10, 2006
    Im taking a java class at school, and I starting writing a program just yesterday in class. I got about 20% of it done, and decided to finish the rest at home. A few days ago, I installed Xcode from the developers tools on the Leopard disk on this iMac. So I emailed myself the text from the code (it compiles and runs perfectly at school) and when I put it in xcode, it wont run. On the old Xcode, clicking build and go would run it if it worked properly, but now it says "debugging of java ended normally" but doesn't run it. I know for a fact that the program does not have any problems.

    I even tried something extremely simple, like System.out.println ("Hi");
    and it does the same thing. Any help is greatly appreciated.

    Oh, and I am running Leopard on my previous-gen iMac.
  2. Gelfin macrumors 68020


    Sep 18, 2001
    Denver, CO
    Sounds like it actually is running. The console output window isn't open by default in XC3. Cmd-Shift-R to open it and you'll probably see your output.
  3. Zwhaler thread starter macrumors 604


    Jun 10, 2006
    That worked, and also I noticed a little console icon at the top of Xcode that works too. Thanks
  4. Jasonbot macrumors 68020


    Aug 15, 2006
    The Rainbow Nation RSA
    lol, i had the same problem after installing dev tools:D

Share This Page