Java not working

Discussion in 'macOS' started by joltaxt, Jul 12, 2011.

  1. joltaxt macrumors regular

    Joined:
    Mar 4, 2011
    #1
    I have a macbook pro that is a little over a year old.

    For some reason Java is no longer working.

    I tried Software Update but Java is still not installed. When I try to go to Java preferences the icon on the stage just appears and disappears.

    I tried to download from the website and get this:
    http://support.apple.com/downloads/Java_for_Mac_OS_X_10_4__Release_9

    This update requires Mac OS X 10.4.11 or higher. Mac OS X Tiger only.

    Anyone know what's wrong? I have no idea what to do. Thank you.
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    A Macbook Pro that is a little over a year old will NOT be running Tiger. You are probably running OS 10.6 or maybe 10.5 but NOT 10.4. You can look for updates on Apple.com and ignore those that aren't for your version of OS X. To check your version of OS X, click the apple icon at the left of your menu bar and pick "About this Mac".
     
  3. joltaxt thread starter macrumors regular

    Joined:
    Mar 4, 2011
    #3
    Wow, it actually worked! Looks like I'm running 10.6. Thank you so much, had no idea what I was doing. much appreciated.
     

Share This Page