Resolved Java SE Runtime version bug?

Discussion in 'OS X El Capitan (10.11)' started by ryankidd17, Sep 1, 2015.

  1. ryankidd17 macrumors regular

    Joined:
    Oct 12, 2014
    #1
    Hey. So I am running OS X Public Beta, build 15A278b. I have been trying to use Eclipse and I get an error message stating that I need JVM 1.7 or higher. However, I have updated to 1.8 from Oracle's website. Java's control panel states I have the latest version.
    Now, if I check Java's version through terminal, it will state 1.6.0_65. But if I request the version inside my Internet Plug-Ins folder, it will state I have 1.8.0_60.

    How can I fix this issue so that Eclipse can use Java 1.8? I have tried deleting all Java files and uninstalling. Then reinstalling. That didn't fix it.
    I'll include a screenshot of the terminal commands and output.

    Screen Shot 2015-09-01 at 6.08.03 PM.png
     
  2. ryankidd17 thread starter macrumors regular

    Joined:
    Oct 12, 2014

Share This Page