Java update broke minecraft

Discussion in 'Mac Basics and Help' started by kamil97, Aug 16, 2012.

  1. kamil97 macrumors newbie

    Joined:
    Mar 13, 2011
    Location:
    in a house
    #1
    Hello.
    Recently, i came across this article on macrumors
    http://www.macrumors.com/2012/08/14/oracle-officially-launches-java-se-7-for-os-x/
    because i play minecraft and run a server on the same computer, i though this update would improve performance. But once i installed it, minecraft wouldn't even start. It would give me the following error:


    Minecraft has crashed!
    ----------------------

    Minecraft has stopped running because it encountered a problem; Failed to start game
    This error has been saved to /Users/kamilrutkowski/Library/Application Support/minecraft/crash-reports/crash-2012-08-16_17.56.22-client.txt for your convenience. Please include a copy of this file if you report this crash to anyone.



    --- BEGIN ERROR REPORT 7b846f1 --------
    Generated 8/16/12 5:56 PM

    - Minecraft Version: 1.3.2
    - Operating System: Mac OS X (x86_64) version 10.7.4
    - Java Version: 1.7.0_06, Oracle Corporation
    - Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    - Memory: 58264120 bytes (55 MB) / 82313216 bytes (78 MB) up to 1221066752 bytes (1164 MB)
    - JVM Flags: 0 total;
    - LWJGL: 2.4.2
    - OpenGL: ~ERROR~ NullPointerException: null
    - Is Modded: Probably not
    - Type: Client
    - Texture Pack: ~ERROR~ NullPointerException: null
    - Profiler Position: N/A (disabled)[failed to get system properties (java.lang.NullPointerException)]


    org.lwjgl.LWJGLException: Could not get the JAWT interface
    at org.lwjgl.opengl.AWTSurfaceLock.lockAndInitHandle(Native Method)
    at org.lwjgl.opengl.AWTSurfaceLock.access$100(AWTSurfaceLock.java:49)
    at org.lwjgl.opengl.AWTSurfaceLock$1.run(AWTSurfaceLock.java:89)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.lwjgl.opengl.AWTSurfaceLock.privilegedLockAndInitHandle(AWTSurfaceLock.java:86)
    at org.lwjgl.opengl.AWTSurfaceLock.lockAndGetHandle(AWTSurfaceLock.java:64)
    at org.lwjgl.opengl.MacOSXCanvasPeerInfo.initHandle(MacOSXCanvasPeerInfo.java:53)
    at org.lwjgl.opengl.MacOSXDisplayPeerInfo.doLockAndInitHandle(MacOSXDisplayPeerInfo.java:56)
    at org.lwjgl.opengl.PeerInfo.lockAndGetHandle(PeerInfo.java:85)
    at org.lwjgl.opengl.MacOSXContextImplementation.create(MacOSXContextImplementation.java:47)
    at org.lwjgl.opengl.Context.<init>(Context.java:120)
    at org.lwjgl.opengl.Display.create(Display.java:858)
    at org.lwjgl.opengl.Display.create(Display.java:784)
    at org.lwjgl.opengl.Display.create(Display.java:765)
    at net.minecraft.client.Minecraft.a(SourceFile:233)
    at net.minecraft.client.Minecraft.run(SourceFile:516)
    at java.lang.Thread.run(Thread.java:722)
    --- END ERROR REPORT 5af0e542 ----------

    Before the update it worked fine. so my question is, how can i remove this update OR how can i make minecraft run again.
    Any help you can give will be appreciated. If it helps, im on a 13 inch macbook pro with 2.3ghz core i5 processor and 4gb of ram
    Thanks :D
     
  2. Dark Dragoon macrumors 6502a

    Dark Dragoon

    Joined:
    Jul 28, 2006
    Location:
    UK
    #2
    Can you open up the Java Preferences app (should be located in Applications > Utilities).

    If you have Java SE 7 listed as well as SE 6, try dragging the SE 7 versions below the SE 6 ones in the list. Then try Minecraft again.
     
  3. kamil97 thread starter macrumors newbie

    Joined:
    Mar 13, 2011
    Location:
    in a house
    #3
    still shows the same error. Tried unchecking it and also nothing
     
  4. kamil97 thread starter macrumors newbie

    Joined:
    Mar 13, 2011
    Location:
    in a house
    #4
    FIxed it.
    all i had to do was download the minecraft.jar again
     

Share This Page