Java won't work

Discussion in 'iMac' started by Holy Cactus, Aug 31, 2010.

  1. Holy Cactus macrumors newbie

    Joined:
    Aug 31, 2010
    #1
    A bit ago I went to the Apple dev. website to try and look for the latest pre-released Java update for my iMac 10.5.8. I downloaded one of them and now I'm unable to run .jar files. When I double click on the file to run it nothing happens and then after awhile a notice pops up telling me to check the console for possible error messages. I then tried running java from terminal via the "java -jar" command. This is what came up:


    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:317)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:280)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:375)


    I've searched all over the web for a solution and the only one I come up with is re-installing my OS but I really don't want to have to do it (don't ask why because it's complicated). I was wondering if there was any other way to fix this problem? I would appreciate and e-mail if you think you know how. Thanks!
     
  2. RRmalvado macrumors 6502

    Joined:
    May 27, 2010
    #2
    Blessing in disguise? ;)

    I would try downloading the latest Apple Java update manually and reinstalling it.
     
  3. Holy Cactus thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #3
    I tried and it says "you already have a newer version of java installed" and then quits.
     

Share This Page