JAVA?

Discussion in 'OS X El Capitan (10.11)' started by Reality4711, Aug 9, 2015.

  1. Reality4711 macrumors 6502

    Reality4711

    Joined:
    Aug 8, 2009
    Location:
    scotland
    #1
    I have just read the JAVA pages from El Capitan works/does not work thread and as usual find them confusing.contradictory.

    If I need to download Java6 from Apple to get my CS5 to work do I then have to update Java for security reasons as per comments on the bottom of the Java6 instruction page.??

    Does doing so negate the Java 6 fix for CS5?

    If so why the upgrade recommendation?

    Simple is good! Simple and contradictory is BAD!

    Regards

    Forever ??? Sharkey
     
  2. jruschme macrumors 6502

    jruschme

    Joined:
    Dec 20, 2011
    Location:
    Brick, NJ
    #2
    Personally, I'm running the latest JDK from Oracle on 10.11 with no issues.

    The update recommendation is because Java 6 has long been deprecated by Oracle and not received any security fixes in several years, so it is vulnerable to any number of exploits. The only reason to install it is some questionably coded applications which expect to find it.
     
  3. Reality4711 thread starter macrumors 6502

    Reality4711

    Joined:
    Aug 8, 2009
    Location:
    scotland
    #3
    Thank you for that.

    However the question was more about installing Java6 to allow CS5 to run on El Capitan and the rather confusing second point made in the Apple support page to keep Java up to date.

    Regards

    sharkey
     
  4. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #4
    Apple's Java 6 and Oracle Java are different implementations of Java. So they don't share most of the vulnerability. Furthermore you can just disable the Java 6 plugin in your browser (if it's not already disabled by default) and be happy.
     
  5. Reality4711 thread starter macrumors 6502

    Reality4711

    Joined:
    Aug 8, 2009
    Location:
    scotland
    #5
    Thank you once again; however my concern is really directed to the use CS5 and the apparent contradiction the of the two Apple document below.[​IMG] [​IMG]

    To be precise , as I can.

    Do I install Java6 after EC upgrade to enable CS5 to run?
    Do I then have to update Java as per second DOC to keep everything else up to date?
    Will this update then disable my CS5?
    If so must I ignore the second DOC?
    Finally will this leave me vulnerable to hacking (etc) and with software that will not work?

    Best I can do.

    Thank You. Sharkey
     

Share This Page