Javascript buttons won't open in any browser

Discussion in 'Mac Basics and Help' started by diannamac, Mar 30, 2011.

  1. diannamac, Mar 30, 2011
    Last edited: Mar 30, 2011

    diannamac macrumors newbie

    Joined:
    Mar 30, 2011
    #1
    For some reason when I click on certain javascript buttons when using my mac, nothing happens. No error message, nada. This has been going on for months now, and it just occured to me to post on a forum.

    It is a serious problem because it prevents me from being able to do my chemistry homework (masteringchemistry.com) on my own computer. What should happen and used to happen was that I clicked on the "hints" button for the tutorial in the homework assignment, and a new window opened up. That is the primary website where it happens, but I have noticed every now a website will have the same type of javascript button (I think) and then I click buttons and nothing happens, so it's gotta be my computer. I have right clicked on the button and selected open link in new window, and still get nothing.

    I have spent countless hours chatting with the tech support for Mastering Chemistry.com. They tell me to turn off pop up blockers, allow cookies, etc, etc. I have all the proper settings for my browser yet it still happens. One time clearing the cache on firefox worked, but then the next day it stopped working again and now clearing the cache does nothing. I have updated java, re-installed it. This is the weirdest problem!

    Once I happened to try it while logged in on another user account on the mac and it worked for a while, but now that doesn't even work. I tried creating a new account, but no luck.

    I have tried Firefox, Chrome, Safari, and IE.

    I am running OSX 10.6.7

    I have a macBook Pro, about 5 years old.
    I also have an eMac that's 8 years old, running 10.4. I hadn't used it in months until I encountered this problem on the macbook. The buttons used to work on it, and they did the first time I attempted an assignment, but the second time, the same thing is happening on that computer too! But I am able to use the University computers (PCs and Macs) with no trouble.

    I consider myself highly computer/internet literate, but this is quite a conundrum.

    And it's such an odd problem, its hard to search for it.

    Please help! Thanks!!!
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    One quick note, Java and JavaScript are completely separate technologies, so reinstalling Java wouldn't have any effect.

    Some things to try; Most browsers have an error console that can be accessed via the Tools menu. Be sure to watch this when you click the links.

    For Firefox, you can try running it in safe mode to see if that improves things.

    Mac has a Console app (/Applications/Utilities/Console), which you can keep open while you go to these sites and see if any relevant messages appear. There will be a number of messages, but just look out for browser related ones.
     
  3. diannamac thread starter macrumors newbie

    Joined:
    Mar 30, 2011
    #3
    Thanks for the info! The error actually stopped happening the day I posted the initial problem (perhaps due to an upgrade in firefox?), and now it started again. I ran the error console in firefox (there are a lot of warnings and errors!) and when I click the hint button it says: Error: hintWindow is undefined
    Source File: http://session.masteringchemistry.com/assets/script/actions_uxo.build1103181001.js
    Line: 179

    This also occurs when running firefox in safe mode.

    Could I be lucky enough to get some sage advice again?? :D
     
  4. Hastings101 macrumors 68010

    Hastings101

    Joined:
    Jun 22, 2010
    Location:
    K
    #4
    I am having the exact same problem, have you found a solution for it yet?
     
  5. Hastings101 macrumors 68010

    Hastings101

    Joined:
    Jun 22, 2010
    Location:
    K
    #5
    Another bump because I want a solution :(. I have had to deal with this problem for a couple of months now on two different Macs and I am a little annoyed that I can't find a solution for it anywhere. In fact, this is the first thread I found that was even dealing with the same problem as the one I'm having. It's like javascript is almost completely disabled across every web browser on OS X, and then magically it works again for a short while.
     
  6. CR93 macrumors newbie

    Joined:
    Mar 4, 2011
    #6
    Antivirus settings

    I also had the problem that I wasn't able to click on javascript buttons on some sites in any of my browsers (FF, Chrome and Safari). But I discovered that this problem was because of the settings in Intego's VirusBarrier X6 that I have installed. Under "surf > information hiding", I tried to uncheck "hide information about my computer and web browser". As the program warned about, this setting may prevent you from using certain websites, and this was the case for me. So if you have some kind of antivirus program or firewall or something installed, it may be worth checking the settings for these.
     
  7. NewbieDewbie macrumors newbie

    Joined:
    Jul 5, 2012
    #7
    Wow, all my searching and searching and this advice did the trick, "Intego's VirusBarrier X6 that I have installed. Under "surf > information hiding" was the problem. I unchecked "Hide information about my computer and web browser" and can finally use javascript buttons.

    Big props to you for that tip!
     
  8. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #8
    It would be best to simply remove VirusBarrier completely. Anti-virus applications are not needed to protect your Mac, and they cause problems like this on a regular basis. Watch for GGJstudios to pop in here with his usual safe computing tips, they are the best solution for protecting your Mac from malware.

    jW
     
  9. talk2pj macrumors newbie

    Joined:
    Oct 19, 2011
    Location:
    Brisbane, Australia
    #9
    Solved it for me, too!

    I just wanted to say THANK YOU!

    This issue on my Mac of not being able to click certain buttons on web pages has plagued me for almost two years. I've had Survey Monkey and Google Apps techs, and my IT tech guy, try to fix it, but to no avail. Incredibly frustrating. I ultimately resorted to doing certain work on my partner's PC.

    But thanks to you, it's now fixed! It was that setting in VirusBarrier X6 all the time. Much appreciated.
     
  10. makdm1 macrumors newbie

    Joined:
    Jul 4, 2013
    #10
    Thank you!


    THANK YOU SO MUCH for this solution! I was having the same problem, having VirusBarrier X6 installed and those surf options checked. After hours of searching for answers tonight plus DAYS of troubleshooting with technical support, this post was the solution. VirusBarrier has been more trouble than it's been worth-- I run into other issues with it that prevents my NAS network drive from mounting for backups. That app has got to go...
     
  11. photoclaws macrumors newbie

    photoclaws

    Joined:
    Sep 29, 2016
    #11
    --- Post Merged, Sep 29, 2016 ---
    Struggled with this problem for years, thought I found the answer, but when I deleted all my Intego VirusBarrier app and files, the problem persists. Its a 2008 MacPro running 10.9.5 . Will probably get new system soon, but would love to finally fix this as too many sites I need to use have dead buttons.

    thanks
     

Share This Page