JavaScriptCore Problems after Security Update

Discussion in 'macOS' started by calumshady, Mar 21, 2008.

  1. calumshady macrumors newbie

    Joined:
    Mar 21, 2008
    #1
    After installing the Security Update 2008-002 SecUpd2008-ppc.pkg and the Safari 3.01 update Safari31UpdPPC.pkg I am unable to start Safari, Mail, Itunes Installer and Software Update. There seem to be a number of people with the same problem.

    I get the crash Logs that look like this

    Parent: WindowServer 466

    Version: 2.0.8 (2.0.8)

    PID: 518
    Thread: Unknown

    Link (dyld) error:

    Symbol not found: __ZN3KJS11Interpreter4markEv
    Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
    Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore"

    Now As far as I can see JavaScriptCore is a Mach-O universal binary with 2 architectures
    JavaScriptCore (for architecture i386): Mach-O dynamically linked shared library i386
    JavaScriptCore (for architecture ppc): Mach-O dynamically linked shared library ppc

    So it would appear that the problem is only with the PPC architecture as no one is reporting problems on i386.

    I have tried repairing permissions and softwareupdate command from a shell
    all to no avail.

    Anyone have any other suggestions ?

    thanks in advance.
     
  2. stevenp macrumors newbie

    Joined:
    Mar 22, 2008
    #2
    software update safari 3.1 mail crash hang os x

    Same thing here. The javascriptcore.framework file was modified at the same time the safari 3.1 install failed (or close to)....says it is missing the symbol

    ZN3KJS11Interpreter4markEv

    just like yours.

    I don't know enough yet. I'm wondering if a java re-install would fix this, or if it is something else. I've heard of people doing and archive and install of OSX and having that work, but I don't want to risk losing files...

    I'm halfway tempted to try and copy this file from another tiger install and see what happens......

    steve
     
  3. Stephen Derenzo macrumors newbie

    Joined:
    Mar 26, 2008
    #3
    Same problem with PPC after security update 2008-02

    Same problem here. I was on the phone with Apple for two hours without resolution. None of the "technical experts" or their immediate supervisors knew of the problem and they could only help me reinstall the system as originally purchased. Mail works but not Safari.
     
  4. stevenp macrumors newbie

    Joined:
    Mar 22, 2008
    #4
    check the apple threads

    I posted the fix that worked for me there!

    You need to force the safari update to run from the terminal(the actual mac terminal program-command line) as the regular software update drop down will be corrupted.. This corrects the broken javascriptcore files that safari,mail,software update etc need in order to launch properly. Search for "newfocus" in the discussion groups and you should find my post. I also had a drive corruption from the failed original update of safari that I needed to buy diskwarrior to fix. I started the mac in firewire target disk mode, hooked my other mac with osx to it, and ran diskwarrior on the startup disk. Now all is good, and I am typing this post on the repaired mac. THis has been a nightmare, but keep checking the apple discussion grups, takes about an hour of poking around, but you can eventually get the info you need to fix this issue, if your problem is the same as mine, without wipe and re-install. I do recommend you backup your entire hard drive first. Got a WD 500 gig mybook at office depot for $169, but it's usb and can't boot off of. Get a big external firewire drive, and you can partition it, and put a mac os install on it. then you can use it to boot if you ever have an issue like this again. booting from the firewire drive will allow you to repair the mac startup disk. If you boot on the startup, you can't repair to the startup. Hope this helps and dont give up!

    Steve
     
  5. charpier macrumors newbie

    Joined:
    Apr 6, 2008
    #5
    ZN3KJS11Interpreter4markEv

    Hi Stevenp, i have the same problem here on a PPC running Tiger but i do not find your post where you explain how you solved the problem.

    you said "Search for "newfocus" in the discussion groups and you should find my post."......

    Any help please?
     
  6. stevenp macrumors newbie

    Joined:
    Mar 22, 2008
    #6
    ixed!! I tried verify permissions and verify hard drive in disk utility. I do have a key error that causes the drive verify to stop.
    Verifying volume “Macintosh HD”
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Keys out of order
    The volume Macintosh HD needs to be repaired.

    Error: The underlying task reported failure on exit
    Disk Utility stopped verifying “Macintosh HD” because the following error was encountered:

    The underlying task reported failure on exit
    1 HFS volume checked
    Volume needs repair

    But, never mind that. for now..

    From the forums I found this...

    "This issue is resolved, thanks karelsf. To run Software Update through terminal, open Applications > Utilities > Terminal, then type:

    sudo softwareupdate -i -a

    Enter your password at the prompt. You'll probably be asked to restart when it's done, which you'll have to do manually. This probably worked because the new Safari update also installed a new WebKit framework, which was the problem in the first place.

    Thanks!

    Mateja"

    Thank the above wonderful folks for sharing!!

    Might not work for everybody, but worked for me, just need to figure out the hard drive error...

    note - the disk error got fixed by disk warrior. But the software update run from the terminal with the command line fixed the big missing java file issue and got everything working again. I had backed up everything before doing this as a precaution. The unsuccesful install that led to this whole issue was due to an failure through the auto software update glitching while installing safari 3.1/ the terminal version of the install does not have that issue.
     
  7. charpier macrumors newbie

    Joined:
    Apr 6, 2008
    #7
    Solution found here

    Hi,

    I found this thread http://forums.macosxhints.com/showthread.php?t=87788 (see post #9), i applied it and it solved my problem.

    I copy here the content of the post from Ronald :

    "Thanks bramley, I reinstalled Safari31UpdTiger.dmg from Apple's website. I used the installer command:

    $sudo -s
    password:my password
    installer -pkg path_to_pkg -target "/Volumes/Macintosh HD"

    I rebooted and Safari, Itunes, Mail is now working properly. Even though I downloaded the update combo, I will not apply it since everything is back to normal."
     
  8. gusapple macrumors 6502a

    gusapple

    Joined:
    Jan 29, 2007
    Location:
    The alphabetically sixth to last state.
    #8
    I get a wierd message when I try to type in sudo softwareupdate -i -a

    I even verified permissions and did it right at startup... Any other ways? (Also, the sudo -s thing is confusing to me)
     
  9. stevenp macrumors newbie

    Joined:
    Mar 22, 2008
    #9
    update

    I don't actually know the tech meaning of it, but I used the command from the post I wrote and it worked for me, the post after that one had something different -the (sudo -s) etc.

    i used in terminal

    sudo softwareupdate -i -a


    Basically you need to force the install of the security update and safari without using the "software update" function from the drop down menu, or the application for update in the finder. It has to be done at a lower level, in the terminal.

    good luck. Keep looking around, the answer is out here. And don't only check your permissions, vereify the actual startup disk, if there is directory damage, that may be another issue, which a program like discwarrior may be required to fix.

    sp
     

Share This Page