Jaybird SB-2 Headphones - iMac Issues

Discussion in 'Mac Accessories' started by KlytusLord, Oct 4, 2011.

  1. KlytusLord macrumors regular

    Joined:
    Apr 11, 2011
    #1
    Hello everyone,

    My SB-2 Headset has a weird issue with my iMac. When paired, two different entries appear in the BT settings, one for "SB2 Headset" and one for "SB2 Headphones."

    If I select the "Headset" output, the sound does come through the Jaybird headphones, but it is on Mono, with terrible sound quality.

    If I select the "Headphones" option, no sound gets piped to the headphones, and eventually the iMac reports an error with the device.

    These same headphones sound just fine on the iPhone 4, where they are simply listed as SB2, with no headphones v. headset distinction.

    On my MBP, the headphones are listed just like on the iMac, but selecting the "Headphones" option works fine and produces good quality, stereo sound.

    Both, the iMac and the MBP are running the same version of Snow Leopard, 10.6.8.

    I am at a loss as to what specifically on the iMac is causing the SB2s to fail in "Headphone" mode and only work in "Headset" mode.

    Any ideas?

    Thanks!
     
  2. ryhno45 macrumors regular

    Joined:
    Oct 13, 2008
    #2
    Same as me :( I have unfortunately not found a fix yet..
     
  3. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #3
    Must be iMac specific.

    I use these headphones on MBA, iphone, ipad and they all work fine. Perhaps the people to ask are the jBird folks?
     
  4. rp777 macrumors newbie

    Joined:
    Nov 26, 2011
    #4
    I noticed the same thing but only when I was wireless synching my iphone. I manually stopped the syncing process and then I was able to listen to music in stereo again. Overall the pairing can be a pain and it seems to be a bit picky at times. Still not sure if I should on my Mac bluetooth on first then turn on my jaybird or vise versa.
     
  5. fatjoadr macrumors newbie

    Joined:
    Nov 26, 2011
    #5
    This worked for me

    Disable the bluetooth connection on your iphone/ipad/ipod and then try an select the Bluetooth headphones in the sound section of your imac system preferences:cool:

    I hope that works for you too, i just try this after a couple of months of not beeing able to use them with my imac XD
     
  6. KingDavid macrumors newbie

    Joined:
    May 3, 2011
    #6
    Excellent

    Nevermind, wrong post to respond to.
     

Share This Page