JB 3G on 3.1.2 to JB 4.1?

Discussion in 'Jailbreaks and iOS Hacks' started by Tronic, Jan 1, 2011.

  1. Tronic macrumors 6502

    Tronic

    Joined:
    Jun 10, 2009
    #1
    Hello, been a while since i've been here for a varying number of reasons. Anyway I have a JB'd 3G on 3.1.2, I know so long ago. I never upgraded and now i'm more than a couple firmwares behind. I'd like to upgrade to the most recent JB firmware which from what i've surmised is 4.1. Is this correct? I read that we are still waiting on a 4.2.1 JB. Can anyone point me in the direction of a walkthrough that will take me through this upgrade process while still maintaining my JB?

    Thanks
     
  2. WiiDSmoker macrumors 65816

    WiiDSmoker

    Joined:
    Sep 15, 2009
    Location:
    Hermitage, TN
    #2
    Don't upgrade to anything 4.x on a 3G. You will be horribly disappointed. It's extremely slow.
     
  3. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #3
    Unless you happen to have the SHSH blobs for 4.1 you're only choice is to upgrade to 4.2.1.

    I agree with WiiDSmoker though. iOS4.x on a 3G is going to be slower than you'd like. Honestly, after upgradeing my wife's and using it, I'm surprised Apple even allowed it.
     
  4. Tronic thread starter macrumors 6502

    Tronic

    Joined:
    Jun 10, 2009
    #4
    oh okay, so since i missed the 4.1 window I'm not able to JB it because I never had a shsh stored in cydia for it? So if I want a JB, the only way is to wait for 4.2.1?
     
  5. WiiDSmoker macrumors 65816

    WiiDSmoker

    Joined:
    Sep 15, 2009
    Location:
    Hermitage, TN
    #5
    4.2.1 is JBable with iPhone 3G. But seriously do not upgrade to 4.x on a 3G.
     
  6. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #6
    You didn't have to upgrade to 4.1 to get the blobs. In Cydia just check the top line for the iOS version numbers. If 4.1 is there then you can upgrade to it. If you use TinyUmbrella you may have it.

    If you don't see 4.1 listed then you can't upgrade to it.
     
  7. Tronic thread starter macrumors 6502

    Tronic

    Joined:
    Jun 10, 2009
    #7
    SHSH iOS 4.0, 4.0.1, 4.0.2, 4.1
     

Share This Page