General JB-7.0.4: New contacts aren't syncing with icloud?

Discussion in 'Jailbreaks and iOS Hacks' started by OverSpun, Jan 30, 2014.

  1. OverSpun macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #1
    I wasn't able to test it with ios6 since I immediately updated from ios6.1JB-

    I added a couple new contacts on my phone and they don't sync or show on OSX iMessage or my iPad.

    Couldn't find this on the forum and I'd assume that its a JB bug?
     
  2. Trevornewell macrumors member

    Joined:
    Mar 27, 2011
    Location:
    Canada
    #2
    You should turn off sync for contacts. Then turn it back on.
     
  3. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #3
    I gave it a shot on my phone but it didn't do anything.=/
     
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    Turn contact syncing off

    Try browsing to /var/mobile/Library/addressbook

    Delete whatever is inside (this WILL remove all your current contacts). Make a backup just in case

    Respring, open contacts app and it should be empty now

    Enable contact syncing in iCloud. Merge contacts. Make a new contact and see if syncs to iCloud now
     
  5. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #5
    It didn't delete anything in the contacts.
     
  6. MarkCooz macrumors 6502a

    Joined:
    Jul 12, 2009
    Location:
    California
    #6
    Must be something wrong with iCloud's server. That shouldn't be a JB bug... Cause that's never happened to me before..

    I'd say check iCloud website and edit a contact from there and see if anything changes on your iOS device.
     
  7. OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #7
    I made a fake contact from icloud and it showed up in my iPhone's contact however it doesn't work the other way. I guess it's not JB but something isn't working right. iCloud is up (http://www.apple.com/support/systemstatus/)

    I feel like restoring the phone but it could be a waste of time.
     
  8. MarkCooz macrumors 6502a

    Joined:
    Jul 12, 2009
    Location:
    California
    #8
    Checked your iCloud settings on your iPhone? Uncheck and Check the contacts pane through iCloud. See if that works.
     
  9. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #9
    Any other accounts (gmail, outlook, etc.) syncing contacts?
    If so, give disabling the other account a try.
     
  10. OverSpun, Jan 31, 2014
    Last edited: Feb 1, 2014

    OverSpun thread starter macrumors 6502a

    OverSpun

    Joined:
    Sep 12, 2006
    Location:
    California
    #10
    I'll give it a shot, thanks
    I always had google contacts disabled and somehow it was on since I upgraded to IOS7. I just disabled it and I'll play with it and see if it caused it. Thanks!

    At this point, I think it was google sync that had turned itself on. It wasn't JB.
     

Share This Page