JB clarification question

Discussion in 'iPad Hacks' started by dogbiskit2, Dec 8, 2010.

  1. dogbiskit2 macrumors member

    Joined:
    Jun 6, 2008
    #1
    Hi all,
    I think I understand my options, but I'd like to make sure.

    My iPad currently has v 3.2.1 on it and I'd like to jailbreak it. However, I also want to upgrade to iOS 4 since some apps need it, and I'd like to wait until the jailbreak becomes untethered. Unfortunately, I was too late and only have the 4.2.1 blobs saved. Am I correct in thinking that my options are:

    - jailbreak with 3.2.1 and live with it (not really an option)
    - upgrade to iOS 4 now, and potentially lose out on being able to do an untethered JB
    - wait (with fw 3.2.1) until the untethered JB comes out and then have (potentially) 1 shot at it

    Is that 3rd 'option' even correct? My understanding is that the blobs are required to revert back to an earlier firmware for the exploit, so if I'm already on an earlier fw, then I won't need it?

    Since there's no telling how long it'll take for the untethered JB to come out, I'm leaning more towards the middle option to take advantage of the new features in iOS4, but I'm not sure. :p

    Thanks in advance!
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    Your got "pretty much" narrowed it down, however you are missing just a small piece of information.

    1- you can stay in 3.2.1 and JB there and wait..no issues there (but you don;t seen to want that)

    2. You can upgrade to 4.2.1 and JB using redsnow, however it is a tethred JB at the moment, to be honest, I don't reboot my ipad as often as I reboot my phone so I am JB with the current solution and haven't had any issue, I had rebooted like 3 times (and run redsn0w each time), not really a biggy. NOW>..you won't lose the chance to use future Jailbreaks, Dev team showed a untethred JB that use the 4.2b3 kernel, you don't have those SHSHs blobs so that option is out for you, however Comex is working on "another" solution that will make the JB untethred as well that it doesn't required downgrade to a older firmware, so when that one is avaliable you can use it no problem - comex said it should be out before xmas.

    Your 3er options is "almost" correct for the same reason, you can wait on 3.2.1 and then JB when the untethed JB comes out, you don't have once shot, when comex released his exploit you can do it over and over until Apple release 4.3.x and even them you should have SHSHs for 4.2.1 so you are good to go.

    Now as i said before you are out of luck for the other untethered way that Dev team reveled today that use 4.2b3 kernel since you don't have any other SHSHs blobs, they "may" release that one just to please some people while comex finish his work (they may not release it at all)
     
  3. dogbiskit2 thread starter macrumors member

    Joined:
    Jun 6, 2008
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Mobile/8B117)

    Cool. I didn't know that Comex's untethered jb won't require the older shsh. That's great info. Thanks again for taking the time to clarify this for me!
     
  4. lokerd macrumors 6502a

    lokerd

    Joined:
    May 2, 2010
    Location:
    Beaumont
    #4
    Why does this all have to be so confusing???

    Let me just ask it this way.

    If we aren't going to upgrade until 4.2.# unteatherd jb is, do we need to do anything now if we are on 3.2????
     
  5. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #5
    It's not confusing if you're paying attention.
    Even if you don't jb now, you should save your SHSH. By the time the untethered jb for 4.2.1 comes out, Apple may be signing for a new iOS. You'd be screwed if you didn't have the blobs for 4.2.1.
    You don't have to be jb to save your blobs. D/l Tiny Umbrella and start saving.

     
  6. lokerd macrumors 6502a

    lokerd

    Joined:
    May 2, 2010
    Location:
    Beaumont
    #6
    Hello fellow Texan!

    Well, I am trying, there just happen to be dozens of post about this and it is hard to sort through it all.

    Ok, so I need to dl my blob, but can I do that if I don't even have 4.2.1? And can I dl a 4.2.1 blob with cydia?

    Thanks!
     
  7. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #7
    Yes, you can download SHSH for 4.2.1 even if you don't have it installed. Just get TinyUmbrella and you'll see how it works.

    In order to use Cydia, you need to be jailbroken. And Cydia doesn't download your SHSH to your computer, it saves them on their server.
     
  8. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #8
    [​IMG]
     
  9. Jakeblu macrumors regular

    Joined:
    Feb 20, 2008
    Location:
    UK
    #9
    Now this really is confusing. Looking to jailbreak my iPad when the untethered JB is released. Currently with 4.2.1 and never JB before. Do I need to download my SHSH :confused:
     
  10. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #10
    Since the JB haven't been release, we DON"T KNOW (yet), however is best practice to ALWAYS save your SHSHs, so go ahead and download Tiny Umbrella and tell it to save your SHSHs (you may need them, you may NOT... as it have been said before, SHSHs blobs are like condoms, is always better to have them and no need them than need them and not have them)
     
  11. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #11
    You should just save whatever SHSH you can, whether or not you jailbreak at that firmware version. That way you guarantee that you can downgrade to that firmware, which may give you more options later. Like let's say 4.3 comes out, and there's no jailbreak for that, or there is a jailbreak but it's tethered, and in order to get an untethered jailbreak, you need to be on 4.2.1. If you saved SHSH for 4.2.1, you're set, you can get the utethered jailbreak. But if you don't save your SHSH now, you won't be able to save it once 4.3 is out.

    Now, it could turn out that 4.3 is jailbreakable untethered, and you won't ever need the SHSH for 4.2.1. But we don't know how it will turn out, so better to save it and be safe, than not save it and be sorry.
     
  12. Jakeblu macrumors regular

    Joined:
    Feb 20, 2008
    Location:
    UK
    #12
    :D:D

    @ Night Springs @ Maturola Thanks chaps :D
     
  13. sfphoto, Dec 12, 2010
    Last edited: Dec 12, 2010

    sfphoto macrumors regular

    Joined:
    Jun 10, 2010
    #13
    3.2 iOS

    I too have 3.2
    Ran Tiny U but was told "you are too late your SHSH were not saved"

    Unclear on how to save SHSH for newer iOS?
     
  14. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #14
    You can only save the SHSHs that Apple is currently signing, at this time you can only save 4.2.1, once you send your info to cydia once, cydia will request all new SHSHs as new firmware is release
     

Share This Page