JB iPhone 3G 4.2.1 - Switching apps in multitask tray crashes springboard.

Discussion in 'Jailbreaks and iOS Hacks' started by Chone, Nov 24, 2010.

  1. Chone macrumors 65816

    Chone

    Joined:
    Aug 11, 2006
    #1
    I have been using ztoggle for multitasking on my iPhone 3G since 4.1, when I upgraded to 4.2.1 everything was working fine, including multitasking. I tried disabling all spotlight options and then performing a hard reset, after that however, multitasking stopped working properly, applications open and close properly and if I exit by using home button and then open them through an icon they switch just fine but if I try to switch using the multitask tray, the iPhone just resprings.

    I tried restoring from older backups, no dice, I even restored the phone, jailbroke it again and restored it from backup and the problem persisted. The only thing I have left to try is restoring the phone and setting it up as a new one but I rather live with this multitasking problem than deal with losing all my contacts, messages, app data and then having to reconfigure everything again.

    The only Cydia apps I have installed are:
    -Installous + AppSync 4.2
    -OpenSSH
    -zToggle

    Does anyone have any ideas? Extensive googling yielded nothing = (
     
  2. hank771 macrumors newbie

    Joined:
    Nov 24, 2010
    #2
    I'm having a similar problem. After upgrading to iOS v4.2.1 and jailbreaking using redsn0w v0.9.6b4, I can't switch from one app to another using the multitasking bar without it crashing springboard. Oddly, I can switch to an app loaded in memory via the multitasking bar while at the home screen (just not while in another app).

    Some others are having the same problem http://modmyi.com/forums/general/738048-3g-4-2-1-multitasking-problems.html. Hopefully this will be fixed soon.
     
  3. gedgeer macrumors newbie

    Joined:
    Nov 23, 2010
    #3
    iPhone 3G - im having the exact same problems.. I jailbroke with redsn0w 0.9.6b3 with ios 4.2.1 an every time i switch to something in the multitasking bar it resprings although as you''ve said up there.. If ive just been in an app then i quit out of it, it stays in the memory and u can click on it in the multitasking bar then.

    PLEASE FIND A SOLOUTION SOMEBODY WHICH HOPEFULLY DOESNT INVOLVE REJAILBREAKING COZ ITS HASSEL
     
  4. lucifiel macrumors 6502a

    lucifiel

    Joined:
    Nov 7, 2009
    Location:
    In your basement
    #4
    Oh wow, could it be that there is a bug in a non-stable jailbreak release? Oh what? Really? NO WAY??

    Such is the way it is, if you're going to jailbreak using tools which aren't out of beta, expect bugs.
     
  5. Arcticguy macrumors newbie

    Joined:
    Nov 26, 2010
    #5
    Ipt2g

    Same problem here on an ipt2g.. I tried with myos and ztoggle and none works..springboard crashes when I try to switch from the multitasking menu.. Probably apple has changed something and they don't let activate multitasking on these devices now... Let's hope ztoggle or myos to be updated and work on iOS 4.2.1!
     
  6. Chone thread starter macrumors 65816

    Chone

    Joined:
    Aug 11, 2006
    #6
  7. Arcticguy macrumors newbie

    Joined:
    Nov 26, 2010
    #7
    Bummer.. I think the transition is pretty much the same.. I don't understand why Apple does this.. If it worked on 4.1 why can't it work on 4.2.1..?? It's senseless.. Just lets hope somebody fixes it whit a tweak on Cydia..
     
  8. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #8
  9. Arcticguy macrumors newbie

    Joined:
    Nov 26, 2010
    #9
    The solution works great. I used WinSCP on Windows to acces and edit the .plist file. You have to install OpenSHH before through Cydia.
    Apparently this solution changes the animation to the old one.
     
  10. kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #10
    I too can confirm this solution works. I just installed OpenSSH and used Terminal/TextEdit.

    The lines on some of the buttons are mildly annoying, but no big deal.
     
  11. Arcticguy macrumors newbie

    Joined:
    Nov 26, 2010
    #11
    True. The side effect of the solution are lines in some buttons.. Like YouTube app, Mail app when its in portrait mode.. But I think I can stand that issue to have the multitasking feature running well..
     

Share This Page