iPhone JB iphone 4 ( 4.3.3 ) ---> ios 5.1.1 + unlock

Discussion in 'Jailbreaks and iOS Hacks' started by Meric, Jun 1, 2012.

  1. Meric macrumors regular

    Joined:
    Nov 24, 2010
    #1
    I have a JB iphone 4, 4.3.3 with baseband 04.10.01

    I just heard about the absinthe 5.1.1 JB and want to update to 5.1.1 What are the basic steps to take?

    I am using a gevey sim to unlock it with the current baseband...

    So should I update 5.1.1 in itunes, JB with absinthe and unlock again? ( how do I unlock with this scenario ? )

    Or update to 5.1.1 preserving baseband, JB with absinthe and keep using the same gevey sim?

    Thanks.

    PS: will I have a problem Jailbreaking if update preserving current baseband?
     
  2. Minhimalism macrumors 65816

    Minhimalism

    Joined:
    Jan 6, 2012
    Location:
    Texas
    #2
    Upgrade using a custom firmware that preserves your baseband using redsn0w or something, and then JB using Absinthe. You will have no problem jailbreaking.
     
  3. Herrera1992 macrumors newbie

    Joined:
    Jul 20, 2012
    #3

    Hey i have the exact same issue except every time i try to restore it with a custom ipsw the restore stops asoon as it begins and i get all sorts of errors.

    any advice :/
     
  4. LandonDonovan macrumors regular

    Joined:
    Jun 24, 2010
    #4
    You need to put the iPhone in pwned DFU mode with redsn0w to avoid the 160x errors.
     
  5. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #5
    Which error?

    Pwned DFU is not a universal solution for all 16xx errors.

    Download 5.1.1 IPSW

    In the latest redsn0w make a custom IPSW from the 1 you downloaded.
    It will look like NO_BB...

    Download TinyUmbrella.
    Connect phone
    Open TU, go to the advanced tab and UNcheck Set host to Cydia.
    Close TU an restart computer if a windows machine.

    In iTunes hit Alt-restore(mac) or SHIFT-restore(win) to restore with the custom NO_BB ipsw.

    After restore jailbreak with redsn0w, during process it will ask if to activate, do so.

    Now on your jalibroken activated iphone with preserved BB install furiousmod in Cydia.

    Your gevey should now work on 5.1.1

    Check iclarified for other tutorials
     
  6. NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #6
    Hi thanks for all your help. I follow your exact steps to create custom IPSW with both the 206 and 208 versions of 5.1.1. I have successfully put the phone into DFW mode with Redsn0w and then open iTune hitting Alt+Restore to restore to the NO_BB IPSW created. I tried restoring to both NO_BB IPSW and both failed. Then I tried downloading and using TU as suggested and also started TSS server when restore to both NO_BB IPSW in iTune and got error 11.

    However, now I can't go back to my jailbroken 5.0.1 as the phone keep go back to restore mode. I can't kick it out of it with both TU and Redsn0w. Just wonder what might have gone wrong?

    I have a Mac with the latest iTune version, could that be the problem? Thanks for any happen as I am worried now my phone is a brick. I did save my SHSH Blob before starting the process though. Please help. Thanks a million :)
     
  7. NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #7
    Hi everyone, so I have tried downloading 5.0.1 and made a custom NO_BB out of it also. Tried to restore to it with iTune having the TU server both off and on and still get errors with iTune.

    I have also tried downloading the old version of Redsn0w 0.9.10b1 and try to use its recovery fix function to kick the phone out of recovery (after selecting the stock 5.0.1), the process started and hang on the screen saying "Exploiting with limera1n with the bar full and completed. However, my phone stays on the screen asking to be connected to iTune and Redsn0w hang on the same screen.

    Now I am much frustrated as I have tried different methods. Can anyone please shed some light. Really need to get my phone back to working. Thank you so very much.

    Oh btw, my phone is an iPhone 4 GSM. Thanks.
     
  8. budgynana macrumors member

    Joined:
    Nov 28, 2010
    #8
    I had bit of a 'mare doing updating to 5.1.1 using a custom firmware myself but I didn't need to preserve the bb so in the end I did it the chicken no messing around way and restored to stock 5.1.1 and used Redsn0w to jb.

    Anyhow... that doesn't help but this might:

    The TU server isn't applicable for iOS 5 onwards so you can forget about using it - I knew this already so I didn't bother with it.

    First, use Redsn0w to create a custom NO_BB - I didn't do this.

    Next use Redsn0w to stitch your shsh blobs to this NO_BB firmware - I stitched straight to the stock firmware.

    Once you have done those 2 steps use the normal DFU mode and custom restore method in iTunes.

    If all goes well then that should work.

    I'm not sure how crucial it is to create the NO_BB firmware before stitching the blobs... but I didn't do it and I could not get my stitched firmware to work. I got a few different errors in iTunes and my phone was stuck in restore mode and my only option was to go to stock 5.1.1. and I couldn't be bothered to keep trying.
     
  9. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #9
    Be more specific in what goes wrong; error messages and such, otherwise we can't help.

    Try to go for 5.1.1 the 208 version, its the latest.
    To go to 5.01 you need your SHSH and the APTicket and stich those to the NO_BB firmware, if you do want to go that way make the NO_BB ipsw first than stitch the SHSH/APTicket to a second custom IPSW.

    Make sure you have your host file pointing to apple again instead of cydia.
    TSS server doent work anymore, leave that alone.

    Make sure you are in DFU-mode, black screen not showing anything, you can also try to go to pwned DFU-mode with redsn0w.
     
  10. NttDocomo, Jul 21, 2012
    Last edited: Jul 21, 2012

    NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #10
    Thank you so much TriJetHero, here's what I did:

    1. Downloaded 5.1.1 208 version for iPhone 4 GSM
    2. Created custom IPSW with redsn0w 0.9.13dev3 (is this a good version or I should use 0.9.14b2?)
    3. Put my phone into Pwned DFU with redsn0w (I did save my SHSH/APTicket with redsn0w at this point with SHSH/Fetch)
    4. Open iTune (Mac version 10.6.3 (25)) and hold "alt/option" key then click Restore
    5. Select the NO_BB IPSW created based on the 5.1.1 208 IPSW
    6. iTune finished extracting, then go to verifying iphone restore
    7. Pop-up shows up saying "The iPhone "iPhone" could not be restored. This device isn't eligible for the requested build."

    Now I downloaded back 5.0.1 IPSW, made a custom NO_BB IPSW out of it and stitched with my saved SHSH blob. Should I use iTune to restore it back to 5.0.1 first then try to upgrade to 5.1.1 again?

    Yesterday night I am so frustrated that I downloaded back redsn0w 0.9.10b1. There I use the Select IPSW button to select stock 5.0.1, then select "Recovery Fix" in hoping to kick my phone out of recovery. redsn0w finished and said the remaining process will run on phone. Then I see a list of white text and the process hung. No I worried that I have already messed out my phone, did I do anything wrong, please please help! Thank you very very much!

    UPDATE: I just stitched my saved SHSH Blob with the NO_BB 5.0.1 custom IPSW and restore my phone with iTune. The restore was successful and I am now back to 5.0.1 with baseband preserved (still 01.59.00 :)

    Now I just need to upgrade it to NO_BB 5.1.1. But I am back to the same loop above with the same error. Any thought or help on what may have gone wrong?

    Strangely now my signal bar always shows with just one bar after restoring to the stitched NO_BB 5.0.1. Is there something wrong also?

    Also don't want to hijack this, please let me know if I should open a new thread for this discussion. Thanks.
     
  11. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #11
    Try regular DFU and your custom NO_BB 5.1.1

    If that doesn't work redowload the 5.1.1 IPSW from here:
    http://m.iclarified.com/entry/index.php?enid=750

    Redo the custom 5.1.1 and try again that should pass cause it it still currently signed.

    The 1-bar signal is a cosmetic issue, make sure you have the latest ultrasn0w installed, that should fix it.
     
  12. NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #12
    Thanks again TriJetHero. I have been downloading IPSW from iClarified so hopefully my IPSW is fine.

    I will try again with the custom NO_BB 5.1.1 208 version of IPSW and see if it works.

    I heard that I can only restore to a custom IPSW with PWNED DFU, wonder how to get into regular DFU and after so, can I still use iTune to restore? Thanks very very much :)
     
  13. NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #13
    Hi TriJetHero, now with my phone restored back to 5.0.1, I redownloaded the 5.1.1 208 IPSW from iClarified and then use the latest redsn0w 0.9.14b2 to create a custom IPSW.

    After that I put my phone into PWNED DFU with redsno0w and then launched iTune to restore my phone with the NO_BB 5.1.1 208 IPSW. Right after extraction and verification, the same error message popped up as followed. Any idea on what could have gone wrong? Thank you very much for all the help
     

    Attached Files:

  14. TriJetHero, Jul 21, 2012
    Last edited: Jul 21, 2012

    TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #14
    Regular DFU

    Connect USB
    Hold home and power until phone powers off, keep holding home and power for 3 more seconds, than release power while holding home for another 10 seconds.

    Phone should now be in DFU, try that.

    You can do it with redsn0w as well.
    Don't use pwned DFU.

    Ps you did have your host file pointing to apple?
     
  15. NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #15
    I think so, I have never changed the host file. Anyway i can check and confirm in my Mac? Thanks
     
  16. NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #16
    Hi TriJetHero, with regular DFU it seemed to have moved a little more but still stopped at the beginning of the iTune restore. It showed an error 1600 as follow. Any thought or idea on what could be wrong. At the mean time let me try to do this on Window. Thanks very much again.
     

    Attached Files:

  17. NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #17
    Strangely I restarted my Mac (I haven't yet restarted after updating iTune) and then restore again (under PWNED DFU) and the process went further. It was able to load up the APPLE icon and progress bar on my iphone. However, as soon as the progress bar started moving, an error 14 occurred (See attached).

    Now I really don't know what is going on. It seems it can only go back to 5.0.1 but cannot move up anymore. Please any help here? Thank you very very much!
     

    Attached Files:

  18. NttDocomo macrumors member

    Joined:
    Jul 8, 2010
    #18
    finally got it to restore to 5.1.1. I stopped using the 208 and tried the 206 version after restarting my Mac and it worked. I think the problem earlier is that I did not restart after updating iTune, although it did not ask me to, I should always restart.

    Then it was just the problem with 5.1.1 208. Wonder what's the difference between 206 and 208. It's kind of tricky, I mean I would have thought that 208 is better but in this case 206 works.

    BTW I have an iPhone 4 that I got the first day iPhone 4 came out and preserved BB ever since. Wonder if that could be the problem and will only work with 206? :confused:

    Alot of hours spent but hope this will help someone in future. Any comment please feel free to chip in :)
     
  19. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #19
    From the iphone wiki

    Error 14
    Custom firmware update fail (PwnageTool until 4.0.1). You have to restore the device with a custom firmware. Update to a custom firmware isn't working. Device isn't bootable. 2
    USB Problem. Check the USB connection and try other direct ports or maybe the USB cable is an older one. Device isn't bootable.
    You're trying to 'update' to a beta firmware instead of performing a restore. Device is still bootable if you kick it out of recovery mode.
    Rebooting your Mac or PC may resolve this issue.
    Root file-system partition size was set too small in the ramdisk's options plist.

    The preserved BB doesn't effect it, enjoy you phone!
     
  20. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #20
    You cannot restore to 5.0.1 unless you saved hash and APTicket file.
    And you have to stitch those to the IPSW.

    Restore to current firmware (5.1.1), no stitching or saved files are necessary just make sure your host file is pointing to Apple, not Cydia

    iClarified.com has tutorials

    Note: I see you figured this out.
     

Share This Page