JB iphone 4- Mobile Terminal wont open - Keeps closing

Discussion in 'Jailbreaks and iOS Hacks' started by Sseguin, Aug 1, 2010.

  1. Sseguin macrumors regular

    Joined:
    Dec 6, 2009
    #1
    Anyone know why I cant open mobile terminal? It keeps closing...
     
  2. mxtime macrumors newbie

    Joined:
    Jul 19, 2010
  3. menist macrumors regular

    menist

    Joined:
    Jun 10, 2010
    #3
  4. Sseguin thread starter macrumors regular

    Joined:
    Dec 6, 2009
    #4
  5. zombiesid1 macrumors newbie

    Joined:
    Aug 3, 2010
    #5
    Tried that, I get a blank app icon, which if I try to open just acts like it opens but doesn't change screen and reverts back to sb. I'm a total nub but I'm trying to change rootpass after a fresh jb so I can learn to not be nub! I jb'd with redsn0w after ios4 upgrade(stupid stupid) and can't use mobile terminal. I used filezilla to ssh the terminal.app folder out of the .zip but when I select ther applications folder in the iphone it reverts to "/private/var/stash/Applications.ySsRvV" is that the correct file to put it in? I'm in as root. is there a FAQ? All I've found is FAQs for macs. I'm on win7.
     
  6. Brother Esau macrumors 6502

    Joined:
    Jun 30, 2010
    #6
    If you are looking for a easy way to change the Default Apple password just download RockApp its the easiest way and anyone can do it! I tried lo9ading Mobile Terminal several times and it does not function properly if it opens at all. even the developer says its not entirely ported into iOS 4.0.1 just yet and not to get high hopes up
     
  7. zombiesid1 macrumors newbie

    Joined:
    Aug 3, 2010
    #7
    Thanks! much simpler.
     
  8. ZenoVT macrumors regular

    Joined:
    Apr 16, 2009
  9. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #9
    Just install MobileTerminal 426 from the xsellize repo.

    To change the root and mobile passwords, you don't even need MobileTerminal if you ssh into the phone using openSSH. I find it much easier to do this on my Mac using CyberDuck than using the small screen with MobileTerminal.
     
  10. sneezymarble macrumors 6502

    Joined:
    Oct 1, 2008
    #10
    I still don't get how people are changing their passwords with the Rock app. I've got it, and I've looked through the settings, but I can't find anything that would let me change my root and mobile passwords.
     
  11. brastein macrumors newbie

    Joined:
    Aug 4, 2010
    #11
  12. anonymous6237 macrumors 6502

    anonymous6237

    Joined:
    Nov 3, 2007
    Location:
    Plano, TX
    #12
    Windows users: use Putty to do the same thing.

    And Aggie: I totally agree with you. I hate using the small screen when I can just do it on my real computer so much easier.
     
  13. Tboy72 macrumors newbie

    Joined:
    Aug 14, 2010
    #13
    Changing root password after JB iPhone 4

    I jailbroke my iPhone 4 says ago and love it. I now need to change the root and user pass word but the mobile terminal app doesn't work in cydia. I read I could do it with Rockapp and installed it, but now what do I do once rockapp is I stalled. I also downloaded mobile terminal with the 426 link provided in this forum, and now have a PDF that I don't know what to do with.

    I'm not new to tech, just to jailbreaking. I had a 3GS that I jailbroke last year and changed the root password just fine. It wasn't as confusing as this.

    Could someone please explain in easy to understand terms how I can change my root password on my iPhone 4? Like I said, mobile terminal isn't working, and I installed rockapp but don't know what to do after that.

    I did install the PDF patch from cydia, and if I can't figure out how to change the passwords, I'll have to just leave them as they are. That's not safe.
     
  14. alpineflip macrumors newbie

    Joined:
    Aug 11, 2010
    #14
  15. iphonefouruser macrumors newbie

    Joined:
    Sep 11, 2010
    Location:
    uk
    #16
    Sorry if this upsets those who know exactly what they are doing, but I am trying to write this as simply as is possible for those who feel they are in an ocean of despair at not getting terminal running and for those virgin terminal users.

    Step by step for changing both mobile and root passwords.

    Both password were changed tonight on my iphone 4 (ios 4.0.1) using the following:-

    Run Cydia and navigate through / Manage/ Sources/ Edit/ select Add
    input http://cydia.xsellize.com

    Use cydia search to find and install the current beta Terminal for iOS4 (just search for terminal as only 2 download options appeared on mine and the ios4 compatible terminal is clearly marked)

    Hit the home button on your phone and run terminal (note that passwords and commands below are shown with quotes. do NOT enter the quotes as they are solely to identify the relevant required input data)

    Type in “su root” and hit RETURN.

    Type the root password “alpine” and hit RETURN.

    You are now logged in as root. Type “passwd” and hit RETURN.

    input a new password (dont do a short simple one) and hit RETURN. You won’t see anything being entered on the terminal screen during password entries so pay attention to what you are typing on the keypad.

    the iPhone will now ask you to retype the new password, so type in your newly created password and hit RETURN.

    Type Exit

    Respring and thats it for the root password.

    Dont forget to change your mobile$ password as well while you are here. It is done almost exactly the same as the root apart from one difference.

    Run Terminal and you will see it says mobile$ on screen and is waiting for a command.


    Type “passwd” and touch RETURN. You will be prompted for the original default mobile “alpine” password here so enter it and hit RETURN

    input a new password (for ease of use use the same new password you used for the root password) and hit RETURN. (as before, you won’t see anything during password entries so pay attention to what you are typing on the keypad).

    it will now prompt you to retype the new password, so type in your new password and hit RETURN. (Nothing is shown to say it has worked here, the software only gives you a message if your confirmation password entry fails to match the new password just entered

    Type Exit

    Respring and thats it, Job done and both passwords changed.

    For a first post on a forum that looks a lot bigger than the 'Hello I am new here' type post I had planned to do.
     
  16. atico5007 macrumors newbie

    Joined:
    Jul 31, 2010
    #17
    Million thanks!!

    Newbie and first post here, want to thank for your help!
    Very helpful! Got terminal working and with new passwords in one set!!
     
  17. iphonefouruser macrumors newbie

    Joined:
    Sep 11, 2010
    Location:
    uk
    #18
    glad it was useful, thanks for the thanks.

    I forgot to add the most obvious bit to the text, make sure you write your new password/s down somewhere safe. It never ceases to amaze me how many people I know that forget passwords and dont have a memory jogger. One of my mates used different passwords and had forgotten one of the passwords by the following day. He still has no idea what his root password now is.
     
  18. luckyblue macrumors regular

    luckyblue

    Joined:
    Jan 7, 2010
    #19
    Thank you, this worked perfectly for me.
     
  19. ZCherub macrumors 6502a

    ZCherub

    Joined:
    Jul 7, 2010
    Location:
    GA, USA
    #20
    Mine did the same thing when installed from Cydia. You can follow all of the fine suggestions here, or alternatively, you can search for the podZombie repository, install that, and download a fully functional version of mobile terminal from there. That's what I did and it works like a charm (I was installing OpenSSH, and the only reason I installed terminal was to change the root password from 'alpine' to 'monkey' ... oops).
     
  20. incanzable macrumors newbie

    Joined:
    Feb 8, 2011
    #21
    feb/8/2011 it worked!!!

    thank you i did exactly as you said here and it worked perfectly.
    im really new and dont understand anything about ssh or changing passwords, i did change my password because a read that my idevice it was at risk with the original password, so i tried to change it and i actually did it with this post. (after reading several posts and not understending jeje ) thanks again :)
     
  21. ddrouse macrumors newbie

    Joined:
    Jul 12, 2008
    Location:
    German Village - Columbus, OH
    #22
    I have had an iPhone since inception, but just got ballsy enough to JB my 3GS yesterday, so I am a real NEWBIE. This is an excellent walk-through! It worked great! Thank you so much!
     
  22. TrulyYuki, May 23, 2011
    Last edited: May 23, 2011

    TrulyYuki macrumors 6502

    TrulyYuki

    Joined:
    Mar 4, 2010
    Location:
    Washington
    #23
    Went to to the first step and add repo. http://cydia.xsellize.com
    I got this warning and am afraid to proceed. Never seen such a warning.

    [​IMG]
     
  23. iFiend macrumors 65816

    Joined:
    Feb 28, 2011
    #24
    It's because you're trying to add a repo that offers cracked apps. Why are you adding that repo?
     

Share This Page