JB/unlock/update with 3g 4.0 8a293

Discussion in 'Jailbreaks and iOS Hacks' started by hackhelpless, Aug 27, 2010.

  1. hackhelpless macrumors newbie

    Joined:
    Aug 27, 2010
    #1
    hey all,

    i finally came across an issue that is over my head and decided it was time i join the forums im constantly looking through and seek some advice. here's my situation: i recently purchased an iphone 4 and now i have an iphone 3g lying around. another family member wants to unlock the 3G and use it as their primary phone. the phone is running on software version 4.0 (8a293) and it is painfully slow. from what i hear, there should be an update to help improve the speed soon...so i want to be able to update the phone, but there is no sim card in the phone (i assume this would be an issue when updating?). from what i've read online, redsn0w beta 0.9.5 would work? and then use hacktivate so i can update later? and what do i use to unlock? one more issue...we just moved to ireland...would an unlock support vodafone?

    thanks in advance for any sort of direction. there's so much information out there on jailbreaking/unlocking i dont want to follow the wrong info and brick the phone.
     
  2. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #2
    It'd be simpler to downgrade the 3G to 3.1.3. After downgrading*, use redsnow 0.9.4 with 3.1.2. Find a wifi connection, access cydia and install ultrasnow. Ultrasnow unlocks your phone.
    Unlock means you can use it with any carrier that uses a SIM card. Is it really that difficult to understand?

    *At no point do you need an AT&T sim. Just continue to jailbreak with redsnow.
     
  3. hackhelpless thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #3
    so ive downgraded, but...

    i can't get redsn0w to work. after downgrading, i get the "no sim card installed" message (not a problem, right?). i attempt to continue to jailbreak but to no avail. redsn0w hangs up on the "waiting to reboot" message. hopefully the solution isn't to difficult to understand. thanks again for any help
     
  4. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #4
    Write out, step by step, exactly what you did. Be sure to detail the software version that you used on everything. Pretend that you're writing instructions for someone else.

     
  5. hackhelpless thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #5
    here's what i did

    since this isn't my area of expertise, i followed some links i found online

    first, i followed the steps from here:
    http://www.redmondpie.com/downgrade...pod-touch-to-iphone-3.1.3-3.1.2-how-to-guide/

    (download 3.1.3 ipsw, dfu mode, restore from downloaded file, used RecBoot to restart)

    at this point i got the "no sim card" message

    next, i followed the steps from here:

    http://www.redmondpie.com/jailbreak-iphone-os-3.1.3-firmware-with-redsn0w-0.9.4/

    i used 0.9.4, pointed the application at the 3.1.2 ipsw file i downloaded and deselected "already pwned". it hangs almost immediately after i put it into dfu mode .

    since i've jailbroken an iphone before, but with pwnagetool 3.1.5, i thought i would give it a try. PwnageTool successfully created a custom ipsw after i provided it some bootloader 46 file i got online, however i was unable to restore with itunes and received the error message that said something along the lines of restore not compatible with this firmware…

    my last attempt was with Spirit. I didn't get anywhere with this application, but it did confirm that i was running on 3.1.3. after all this i went back to step one and restored from the original ispw again just start fresh.

    i am working on a mac, thanks
     
  6. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
  7. hackhelpless thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #7
    i did not try 0.9.5. Is that only for 4.0+ firmware? If it is, I would need to upgrade to 4.0.2, download the 4.0 ispw and point redsn0w at it? The instructions at the bottom of that page for downgrading and using rslite to avoid the 1015 error look nauseating...can that be skipped??
     
  8. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #8
    Probably easier to restore to 4.0+. JB with Redsn0w 0.9.5 beta. Make sure to uncheck multitask and maybe homescreen wallpaper too. That should make speed on 3G & 4.0+ OS fine.
     
  9. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #9
    Turn off all the spotlight searches also. Stops the indexing. Should make the 3G run OK on 4.x.x firmware.
     
  10. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #10
    There's perhaps a couple of things that might be at issue.
    DFU mode might not be done correctly. Make sure you're doing 3 secs power, 10 secs home and power and 30 secs home (although I've never had to hold home that long).
    Use this DFU when you redo the downgrade.
    Sometimes a case can interfere with DFU, which happened to me when I jailbroke my co-worker's phones.
    When you check the options in redsnow, keep it simple and uncheck everything but cydia. It may or may not do anything, but that's how I did the ones I JB.
    Of course, 4.x is an option, but 3G runs best in 3.x and your 3G can downgrade (as opposed to the 3GS). IMO, it's better to stick to 3.1.3.
     
  11. hackhelpless thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #11
    success!

    finally got this to work by updating to 4.0.2, jailbreaking with redsn0w 0.9.5 and unlocking with ultrasn0w. not sure why i had issues with downgrading to 3.1.3 but thanks for the advice everyone!
     

Share This Page