Jedi Knight 2 Macbook problem

Discussion in 'Mac and PC Games' started by HdVaderII, Nov 2, 2008.

  1. HdVaderII macrumors newbie

    Joined:
    Nov 2, 2008
    #1
    Hey, I'm new to this fourm, and I have a problem that I could use some help on.
    I recently bought Jedi Knight II for my macbook. I installed it, and downloaded the UB patch, but when I try to play it, the app icon comes up in the dock, shows the blue dot under it that means it's on, but the game does not run. Instead the app sits on the dock, and my computer emits a very annoying buzzing noise.

    I have a mac OS X Macbook, Leopard 10.5.5, Intel Core Duo, 2.4 Ghz, with more than enough space.

    Also has 2GB of memory

    Graphics/Displays:
    Intel GMA X3100
    144 VRAM

    If anyone could shed some light on what's wrong, that'd be very helpful
    Thanks in advance,
    HdVaderII
     
  2. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #2
    Yea that happened to me too. Apparently, the UB patch does not work or is not meant for Leopard. I have not heard of anybody playing JK II successfully on a macbook running Leopard.
     
  3. HdVaderII thread starter macrumors newbie

    Joined:
    Nov 2, 2008
    #3
    Does anybody here know of a way around this problem?
     
  4. Xavier macrumors 68020

    Joined:
    Mar 23, 2006
    Location:
    Columbus
    #4
    Not really sure of how to make it work, because JK2 and JKA both run perfectly fine on my MBP. :confused:
     
  5. HdVaderII thread starter macrumors newbie

    Joined:
    Nov 2, 2008
    #5
    That's interesting, I tried to play the JKA demo, and got the same problem.
    What's your graphics card?
     
  6. EvanM07 macrumors newbie

    Joined:
    May 19, 2008
    #6
    I am currently playing JK II on my macbook. All I did was install from the disk and then i downloaded the 1.03 and 1.04 patches for the game. Runs perfectly fine.
     
  7. sfmalone macrumors newbie

    Joined:
    Dec 26, 2008
    #7
    Buzzing noise

    I've experienced the same problem. Installed the patches and still get a buzzing noise. Running JK2 on an intel macbook. Any one come up with a solution?
     
  8. lookard macrumors newbie

    Joined:
    Jan 12, 2009
  9. nellsypie macrumors newbie

    Joined:
    May 31, 2009
    #9
    yeah I have the same problem...has anyone found a solution? its a fantastic game, and really couldn't wait to play that level which is only in the demo!
     
  10. Brad Oliver macrumors regular

    Joined:
    May 14, 2003
    Location:
    Phoenix, AZ
    #10
    If you have an Intel GMA 3100 card, it does not support 16-bit OpenGL, which is what the game uses for a default. As a result, the game will fail to launch on that chipset. See the post here for a file which will force the color default to 32-bit for those cards.

    As for the rest of you, there was a Rev. D patch that we released in December for the Jedi games to take care of the other issues. I'd suggest you all download that if you're still having troubles.
     

Share This Page