Jedi Knight Games (Universal); gamepad doesn't work correctly

Discussion in 'Mac and PC Games' started by alexzi, Jul 1, 2007.

  1. alexzi macrumors newbie

    Joined:
    Jun 29, 2007
    #1
    Hi,

    I'm glad to see that Aspyr has made Universal updates to both Jedi Knight II and Jedi Academy. The problem, however is that the gamepad doesn't work correctly. I assign button numbers to my gamepad (from holding down 'option' upon loading). The game pad will work *however*, it settings are forgotten when the game quits, and the gamepad keys must be re-assigned everytime the game loads.

    Anybody have a solution. I don't know if this is an Aspyr issue or a HID issue (or both). I thought this may be the manifestation of a permissions issue; but I don't think it is.

    Any advice?
     
  2. bmb012 macrumors 6502

    Joined:
    Jul 25, 2006
    #2
    It probably is some permission issue... you could try deleting your preferences file for the game.
     
  3. fblack macrumors 6502a

    fblack

    Joined:
    May 16, 2006
    Location:
    USA
    #3
    I had similar issues awhile back, also with other games. I found that the game was just not recognizing my pad (a logitech). Movement sort of worked but that was it. I ended up picking up usboverdrive and that solved all my problems. However, if the pad was working before the update then trashing preference file and repairing permissions would be a good start.

    good luck:)
     

Share This Page