OS X Jedi Knight Jedi Academy help

Discussion in 'Mac and PC Games' started by swafellon, Feb 2, 2014.

  1. swafellon macrumors newbie

    Joined:
    Feb 2, 2014
    #1
    Hey everyone,

    So I am currently using a 13" MBP. It is 10.6.6 and has a 2.3 GHz Intel Core i5 processor. Today I was feeling a bit nostalgic and figure I would bust out the old JKA and boot it up. Well I installed the game and all went well, but then when I try to open up the game on start up it starts making this annoying humming noise and then crashes. So my question is; has anyone else had this problem and is there a fix to it?
     
  2. swafellon thread starter macrumors newbie

    Joined:
    Feb 2, 2014
  3. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #3
    A bit more information would be useful. What version of Jedi Academy are you running, MAS or DVD, or Steam? Have you applied the latest patch? Can you describe the. "Humming noise" a bit better? Is it from the SuperDrive? Have you sent a crash log to Aspyr?

    Are you really on 10.6.6, or did you mean 10.6.8? Update if you can.
     
  4. swafellon thread starter macrumors newbie

    Joined:
    Feb 2, 2014
    #4
    The version of the game I am not sure about. No where on the disk or case does it say DVD like most OSX games do. It is most definitely not from steam but that is the most that I know. On the back of the case at the end of the fine print at the bottom it says "10610-1TCA" if that is a version number of something hopefully that helps.

    I know it's still PPC application which is why the computer is on 10.6.6 because I partitioned part of my hard drive and reinstalled the snow leopard(i believe though I'm not positive, it's just whatever OS software 10.6 is) disk. Also yes I'm sure I can update it and I will do that.

    As for the humming noise, it literally is just a loud HMMMMMMMMMMMM coming out of the speakers then the application crashes, that's the best I can do for that.
     
  5. McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #5
    I have the game, but I haven't installed it. I might give it a try over the weekend and then update you on my test. I can run Snow Leopard too.
     
  6. Nermal, Feb 6, 2014
    Last edited: Feb 6, 2014

    Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    I'm 90% sure that there's an Intel version available; updating to that is probably the first thing you should do.

    Edit: Here you go. Looks like you need to install the "Rev E" Intel update, then you can put "Rev F" on top.
     
  7. swafellon thread starter macrumors newbie

    Joined:
    Feb 2, 2014
    #7
    Installing the patch didn't work. So I uninstalled the game and I'm just going to start over from square one again and see if anything changes this time.
     
  8. swafellon thread starter macrumors newbie

    Joined:
    Feb 2, 2014
    #8
    There was no difference. Nothing changed at all.
     
  9. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #9
    Send Aspyr a copy of that crash log.
    Maybe they can figure it out.

    IMO, the easiest and best long-term solution would be to upgrade your OS and get the latest version of the game from the MAS or Steam that runs on 10.7+. Perhaps Aspyr can hook you up with a code if you send them a pic of your disk. Worth asking.
     
  10. swafellon thread starter macrumors newbie

    Joined:
    Feb 2, 2014
    #10
    Yea I am running Mavericks right now as well. I had partitioned my hard drive. And thats not a bad idea, emailing Aspyr and hoping for a code. I just didn't want to pay for a game that I already own.
     
  11. swafellon thread starter macrumors newbie

    Joined:
    Feb 2, 2014
    #11
    Thank you very much Cougarcat! I contacted Aspyr with my predicament and attached a photo of my game disk and case and then sent me a Steam code to retrieve a copy of the game! So thank you again for that and thank you to everyone else who tried to help me solve my problem.

    P.S. Sorry for the double post.
     
  12. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #12
    Great! Glad to hear it.
     

Share This Page