Jerky trackpad and mouse

Discussion in 'Mac Accessories' started by bryan85, Apr 22, 2015.

  1. bryan85 macrumors regular

    Joined:
    Jun 18, 2010
    #1
    using the trackpad and magic mouse on my iMac has recently become very jerky. i've changed the batteries and rebooted the machine multiple times. the cursor doesn't move across the screen smoothly and sometimes jerks to the end of the screen whichever direction i was trying to move it.

    any ideas?
     
  2. southerndoc macrumors 65816

    southerndoc

    Joined:
    May 15, 2006
    Location:
    USA
    #2
    Known bug with 10.10.3.

    You can try disabling handoff (general tab in system preferences) and see if that helps.

    Report it to apple at http://www.apple.com/feedback/macosx.html so they will bump it up on the list of bugs to fix.
     
  3. bryan85 thread starter macrumors regular

    Joined:
    Jun 18, 2010
    #3
    Ugh... these bugs really suck. Thanks for the info! Feedback sent.
     
  4. Toltepeceno Suspended

    Toltepeceno

    Joined:
    Jul 17, 2012
    Location:
    SMT, Edo MX, MX
    #4
    One thing you can try if you are using wifi is change automatic channel in your router settings to either 1 or the highest. I was getting bad interference, messing with bluetooth, until I did this.

    I am getting no interference in 10.10.3 after doing this, so the "known bug" is not affecting me.
     
  5. bryan85 thread starter macrumors regular

    Joined:
    Jun 18, 2010
    #5
    This seems to have worked. Guess I'll try enabling it again after the next update.
     
  6. southerndoc macrumors 65816

    southerndoc

    Joined:
    May 15, 2006
    Location:
    USA
    #6
    You may want to try this (which worked for me):

    Shut down your iMac.

    Boot up in safe mode (hold down the shift key until you see "safe mode" written in red in the upper right menu bar). Open disk utility and repair permissions. Shut down your computer again.

    Reset the SMC. With an iMac, unplug it for 15 seconds. Plug it up for 5 seconds then turn it back on. One this completely boots up, shut down the computer again.

    Reset the PRAM. Turn on the computer and hold the command + option + P + R buttons simultaneously until you hear the chime TWICE. Allow it to boot fully.

    That actually fixed my issue (with handoff enabled).
     

Share This Page