Jnl: Journal Start/End Pointers Reset! Any use in trying to fix this?

Discussion in 'Mac Basics and Help' started by MoscowErik, Jun 24, 2007.

  1. MoscowErik macrumors newbie

    Joined:
    Jun 24, 2007
    #1
    So, I have read numerous times over about this problem. I have tried everything to fix it yet I cannot anymore. I am giving this problem to you guys to help. However, I think it may just be best to buy a new hard-drive.

    So here is the problem:

    I have noticed for the last few weeks that my Powerbook has been running very slow. And thus I decided to run a few tests. The tests came back negative from the disk utility on the mac (well they said they fixed the problem) however there was one glaring problem.

    Under the S.M.A.R.T. Status it read - Failing.

    The computer worked still at this point. Then I shut it off. Got the strange blinking globe which after 2.5 minutes went to the flashing mac finder folder for 2.5 minutes then the computer finally loaded. Still very slow.

    Thus, I came online and read something about this problem. The recommended solution was to do a cmd 's' start. Then do a fsck -yf run. I did this - it turned up some errors but said it repaired the Macintosh HD volume.

    So then the computer worked for about a week - still slow however.

    Then here is where my real problems began. I got the internet which meant I would be running lots of files at once. Now the computer began to freeze then finally catch up and work again - this was happening constantly. So then I decided to give the computer a break. I turned it off for about 2 hours. Came back and then I got the ominous Grey Apple screen and the forever spinning loader.

    So I went back and reset the PMU (thinking that it was a power management issue) then did a fsck -yf and then the computer worked again - but only for about 2 hours. Now we are at the point where I am at now.

    The last errors I got were the following:

    disk0s3: I/O error (3 times)
    Overlapped extent allocation (file 54419d)
    Jnl: do_jnl_io: strategy err 0x5
    Jnl: replay_journal; could not read journal entry data @ offset 0x6b3a00!
    Jnl: journal_open: error replaying the journal!
    hfs: early jnl init: failed to open/create the journal (retval 0)

    The computer at this point would still allow me to do the fsck -yf process.

    Now the only thing that comes up when I do a cmd 's' launch is the following:

    BSD root: disk0s3, major 14, minor 2
    jnl: journal Start/end pointers reset! (jnl 0xld3fdc4; s 0x609400 e 0x6b3a00)

    Then it does nothing. I cant even run a fsck -yf command or anything.

    Does anyone have any idea what is wrong.

    Is this something that I can fix myself or should I go to some sort of specialist. I am thinking of just upgrading to a 160GB hard drive which would likely solve all the problems and give me 100GB more!

    But I would like to be able to save some of the documents on my computer, but it is not that vital.

    Also - I am in Moscow and forgot to take with me the disks so I have no way of using any of the restore disks that came with the Mac.

    Also - My computer is running OSX 10.3.9.

    The thing that caused me to shut down the computer for the last time was that upon trying to load MSN Messenger (how ironic and typical) it got to the sign in screen and then just froze and would not respond to even a force quit (typical of microsoft).

    So if someone could help me that would be great. Or do you think it would be too much of a hassle to fix and that I should just upgrade to the 160GB hard drive? Would this solve all my problems though?

    Now just to update:

    I have done a PMU reset, zapped the PRAM & NVRAM, fsck -fy, tried to boot into safe mode - nothing works.

    Now when I log into the computer using the single user mode - It runs a for a bit then finally turns up with this:

    BSD root: dsk 0s3, Major 14, minor 2.
    JNL - Journal Start/End Pointers reset! (jnl 0x1d3fdc4; s 0x609400 e Ox6b3a00)

    Then it seems to freeze here as I can no longer do anything or even get an option to type.

    I do not have any of the start up disks - I left them at home and will not have access to them for 6 months. I am thinking my best bet is to just replace the hard-drive altogether? Does anyone have any other suggestions?

    Also, although I would like some of the files on the computer it is not completely necessary that I have them - so I do not care to save them. Though I would like to, but it is not necessary.

    Is my surest bet just to replace the hard-drive?
     
  2. valexa macrumors member

    Joined:
    Nov 3, 2007
    #2
    yep, what you are describing and "journal start/end pointers reset" is a sign of disk hardware failure
     

Share This Page