'Join CD Tracks' works no more in iTunes 9

Discussion in 'Mac Apps and Mac App Store' started by elgarfan, Sep 18, 2009.

  1. elgarfan macrumors newbie

    Joined:
    Sep 18, 2009
    Location:
    Seattle,WA
    #1
    This has me totally flummoxed.

    I have: a MacBook 13" purchased last December.
    I'm running: 10.6.1 and iTunes 9.

    This evening I was ripping some classical CDs (iTunes is not 'classical friendly', no news there) and was able to join CD tracks several times. But after ripping one CD, I realized I had forgotten to join the CD tracks. After deleting the music, I tried again, but no go. The computer remembers past settings (this has always been the case), so that CD was useless.

    But all of a sudden, whatever new CD I put into my computer, the 'join tracks' feature was always dimmed.

    I have restarted the computer and even taken it offline, but no go.

    I got my old 12" PowerBook out and the 'join tracks' worked fine.

    So what is going on with my new MacBook? Any ideas? Please don't tell me to check permissions, that has never solved anything in all the years I've been using Macs.
     
  2. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #2
    I've never even seen such an option in iTunes. If there is one it would have saved me a lot of trouble with my classical cd collection. :mad: Where is/was this option?
     
  3. ChrisBrightwell macrumors 68020

    ChrisBrightwell

    Joined:
    Apr 5, 2004
    Location:
    Huntsville, AL
    #3
    Do you have 2+ adjacent tracks selected on the CD before you rip it?
     
  4. elgarfan thread starter macrumors newbie

    Joined:
    Sep 18, 2009
    Location:
    Seattle,WA
    #4
    Yes.

    @mac2x: joining CD tracks is easy when it works. After inserting CD and the track names come up, highlight any adjaent tracks, go up to 'Advanced' and there should be an option to 'Join CD Tracks'.

    But lately on my computer it's always been dimmed out.
     
  5. OriginalFormula macrumors regular

    Joined:
    Apr 14, 2009
    #5
    Try ripping them in XLD instead of iTunes. Ripping as one big file works every time.
     
  6. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #6
    It worked fine for me on a white MB w/iTunes 9 and SL when ripping an audiobook and using join tracks.
     
  7. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #7
    Thanks! I'll give it a try and see what happens...
     
  8. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #8
    It works perfectly for me. I can't thank you enough for pointing me to it. But I hope you can figure out what's keeping it from working for you. ;)
     
  9. Mrspy macrumors newbie

    Joined:
    Jul 10, 2010
    #9
    I'm having the same problem

    Hi there, i also cannot join tracks on my itunes(version 9 i think)See i put the cd's in and Itunes will only let me join like 5 3 cd audiobooks before it blanks out. And now it seem to be getting shorter!!! i had to make a new user and get back on Itunes and it only let me make 2 before blanking out. What the heck is going on??? Why is the joining tracks going dim after a certain number of audiobooks. Here's what i do, i put the cd in, i highlight every track(which are all in order) then i go to advanced and then to join tracks. Please help, apple won't help me out. :p
     

Share This Page