Joining a Active Directory Domain with xp pro on bootcamp

Discussion in 'Windows, Linux & Others on the Mac' started by rodrigo7x, Dec 25, 2008.

  1. rodrigo7x macrumors newbie

    Joined:
    Dec 25, 2008
    #1
    Hi,

    I have a couple of virtual machines (xp) and was learning about server 2003. I successfully join the ad domain within the vmware xp virtual machines to the server2003. I created roaming profiles but was not able to deploy software because the roaming profiles could not get access to start the windows installer service. I was adviced it was due to vmware issues and it won't happen. So I tried to join the domain with the bootcamp partition to try this out from bootcamp. However, I was not even able to join the domain from bootcamp.
    When I go to tcp/ip to join the 192.168.2.7 DNS server (the w2k3 server) I automatically loose internet connection (which doesn't happen when I do this same act in vmware). Then, I try to join the domain by going to change ID under computer name and the first error I get is that the user account is not recognized (in vmware it is). Next it asks for the computer name (leapord) and the domain (I type in casamericarealt which is the ad domain I want to join). I get an error that the domain doesn't exist.
    What is weird is that I can also run this same bootcamp xp pro machine in vmware, where I can join the domain just fine if I choose.
    I have read some posts that other mac users have not been able to join a domain in bootcamp either but no one has posted a solution.
    Can bootcamp join a windows domain????? If anyone knows I would greatly appreciate your help and response. Thank you.
     
  2. rodrigo7x thread starter macrumors newbie

    Joined:
    Dec 25, 2008
    #2
    Yes bootcamp can join windows domain

    Hi,

    I just finished joining my windows domain. This is where I messed up. My wireless was picking up an open ssid and automatically connecting to it so I had a weid ip 192.168.111.xx. Well, I was trying to set the DNS server to be 192.168.2.7 because that's what my DNS server is but I would loose internet of course since those masks don't match. Well, I saw I was on the wrong network so I joined my wifi here with my router. I got in my netmask and then was able to join a domain just like my virtual machines do. I also was able to change tcp/ip to the correct DNS server.

    Another good thing is that in the bootcamp installation I am able to start or stop the windows installer service at will, the wmi and the rcp services which I understand are needed for software deployment to work. My windows installer is set to manual. I read in Microsoft support that when the software is deployed it will turn on.

    The bad news is that software is still not getting deployed. I was hoping someone would be kind enough to help me out with this software deployment issue. Thank you in advanced for your efforts.
     

Share This Page