Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

starstreak

macrumors 6502
Original poster
Dec 5, 2004
456
11
I couldn't find the answer to this. Under Journaling Schedule---> Schedule (enable On/GREEN)--->I select a time, but I CANNOT select the days to get reminded.
Pop up says " Turn on Notifications in settings"
I go to settings---> Notifications--->"Journaling Suggestions" (Its the only thing I can find with Journal in it) and its enabled.

What am I missing if I want to set a reminder every day at a set time?
 

Apple_Robert

Contributor
Sep 21, 2012
34,665
50,485
In the middle of several books.
The option is there for me under settings > Journal. You were looking in the wrong place.
 

Attachments

  • Screenshot 2023-12-11 at 5.42.39 PM.jpeg
    Screenshot 2023-12-11 at 5.42.39 PM.jpeg
    58.2 KB · Views: 159

starstreak

macrumors 6502
Original poster
Dec 5, 2004
456
11
Settings > Journal > Journaling Suggestions > Suggestion Privacy Settings > Clear history > close Journal app and reopen. Now you can set a schedule.
I went to settings—->journal
But no journaling suggestions to go to. If I turn it on, nothing new opens. So no privacy settings
 

Attachments

  • IMG_5121.png
    IMG_5121.png
    206.6 KB · Views: 43

starstreak

macrumors 6502
Original poster
Dec 5, 2004
456
11
I went to settings—->journal
But no journaling suggestions to go to. If I turn it on, nothing new opens. So no privacy settings
Ok I did nothing but close all open apps including journal again. When I opened journal, it wanted to make a schedule when I clicked next, it asked for permission and now it works. No idea why it worked now.
 
  • Like
Reactions: H_D

raleighawesome

macrumors newbie
Dec 12, 2023
2
2
Ok. Same here. Quitting all apps did the trick for me too.
I tried deleting the app first but that didn’t do it. Once I quit all apps and launched journal again I received the notification splash screen to allow notifications. Now I can set my schedule.
 
  • Like
Reactions: Alpa1721 and istvan

Alpa1721

macrumors newbie
Dec 24, 2022
9
5
Apple botches everything all the time with these low- to medium-severity glitches, I honestly don't know what's gotten into them.
 

chrismac2

macrumors regular
Jan 14, 2008
195
167
Seattle, WA
Ok. Same here. Quitting all apps did the trick for me too.
I tried deleting the app first but that didn’t do it. Once I quit all apps and launched journal again I received the notification splash screen to allow notifications. Now I can set my schedule.
You don't have to quit all apps, just the Journal app. For some reason (a bug?), but you will not be able to set up a journal schedule until you've received the "hey you can schedule reminders to journal" message when launching the Journal app. Force quitting the Journal app, and opening again, will force that message to come up, after which you can "allow" notifications for the app.

They should just make this part of the first launch, rather than a subsequent launch.
 

raleighawesome

macrumors newbie
Dec 12, 2023
2
2
You don't have to quit all apps, just the Journal app. For some reason (a bug?), but you will not be able to set up a journal schedule until you've received the "hey you can schedule reminders to journal" message when launching the Journal app. Force quitting the Journal app, and opening again, will force that message to come up, after which you can "allow" notifications for the app.

They should just make this part of the first launch, rather than a subsequent launch.
I did completely delete the app, redownload and try again with the same result. That would certainly handle quitting the journal app. It was only after I quit all apps, that I managed to get the message you are describing.
Obviously I don't think quitting all apps is required. Someone will inevitably figure out which one. Hard to replicate since it's now working. But I wonder if it's the Settings that needs to be restarted.
 

chrismac2

macrumors regular
Jan 14, 2008
195
167
Seattle, WA
Deleting the app didn’t help because once reinstalled you are starting from scratch. For some reason, only the second clean launch triggers the “click to allow notifications “.
 

H_D

macrumors regular
Jun 14, 2021
234
259
Same problem, same solution with closing all apps worked – restarted Journal after a while and it asked for permission for scheduling notifications.

BTW, since the last update Stoic offers almost identical functionality and otherwise offers more in terms of journaling. Nice app with a solid lifetime-pricing.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.