Just a 1 Movie Not Crossing to ATV

Discussion in 'Apple TV and Home Theater' started by Dr. Dastardly, Apr 24, 2008.

  1. Dr. Dastardly macrumors 65816

    Dr. Dastardly

    Joined:
    Jun 26, 2004
    Location:
    I live in a giant bucket!
    #1
    I Recently got an Apple TV but when I try to rip and encode my copy of Mulan to .Mp4 and import it into iTunes it never crosses over. It plays fine in iTunes and all other movies cross over fine. I tried not syncing ANYTHING except Mulan and it still doesn't detect it.
    Has anyone ever had a problem like this? I've searched the forums and google and haven't seen anything like this.

    Also kind of unrelated but is there any benefit to encoding to h.264 instead of .mp4. Theres quite the amount of hype for h.264 but I don't see the difference and would rather not tax my G4 with a 10 hour encode time if I don't need to.
     
  2. 126351 Guest

    Joined:
    Sep 17, 2007
    #2
    The bitrate is most likely spiking above what the aTV can handle (I think it must be held in the file ID somewhere).

    28 Weeks Later was spiking too high for me so I modified it and now it syncs to the aTV.
     
  3. Dr. Dastardly thread starter macrumors 65816

    Dr. Dastardly

    Joined:
    Jun 26, 2004
    Location:
    I live in a giant bucket!
    #3
    How much is to much? Do you modify it in handbrake, so I would have to re encode?
     
  4. mikenike192 macrumors regular

    Joined:
    Feb 19, 2008
    #4
    i have the same problem even though all my movies are ripped at 2000kbps at all identical settings two of my movies dont sync up with it to stream over
     
  5. 126351 Guest

    Joined:
    Sep 17, 2007
    #5
    I believe that even if you set a constant bitrate, it can still spike above what aTV can handle unless you specify a vbv-maxbitrate setting in Handbrake.

    You should try the Handbrake forums for more information about this.
     
  6. HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #6
    Another idea. If you are using the latest Handbrake and 5.1 audio, make sure you haven't left that file as .mp4 (it should suffix with .m4v). Since Handbrake sometimes defaults with the former, the same thing happens to me from time to time. Then I notice, change the suffix and :apple:TV immediately adds it to its list.
     
  7. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #7
    In the preferences you can tell HB to always use ".m4v" for mpeg4 encodes instead of .mp4. That should help prevent this from happening.
     
  8. Divindude macrumors member

    Joined:
    Sep 6, 2007
    #8
    I had problems when encoding with AC3 (5.1 dolby) and changing the extension back to .mp4 from .m4v. When I'd to that, it would import into itunes and play. Wouldn't sync to my ipod or appletv. If you use AC3 audio you must leave it m4v.
     
  9. HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #9
    Yes, that is a nice feature on the Mac side. But, if he's using a Windows version of Handbrake, how does he do this? Perhaps I'm just missing an option in that version of this (great) program?
     
  10. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #10
    Well, there isnt a global preference for the wingui, if you use chapters it will use .m4v, but there is no pref to just automatically use it instead of .mp4
     
  11. Dr. Dastardly thread starter macrumors 65816

    Dr. Dastardly

    Joined:
    Jun 26, 2004
    Location:
    I live in a giant bucket!
    #11
    So say I'm using Hand Brake on OSX and I want to encode for use on the Apple TV. I would normally select the Apple TV preset and set the encode from h.264 to MP4 (for time sake), check two pass encoding, then hit go.

    Assuming the encode successfully completes in iTunes and runs fine on the Mac but won't cross to the Apple TV, is there anything that I should set to make sure 100% of .mp4s will cross over successfully?
     
  12. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #12
    Well, realize that if your now changing the encoder to ffmpeg, the atv has less bitrate tolerance, only 3000 kbps so you are very possibly getting too high of a bitrate spike.

    Other than that just make sure your using the .m4v file extension.
     
  13. Dr. Dastardly thread starter macrumors 65816

    Dr. Dastardly

    Joined:
    Jun 26, 2004
    Location:
    I live in a giant bucket!
    #13
    So how high is to high? Is their a minimum?

    So essentially if I do .m4v or h.264 instead of .mp4 it shouldn't have any problems?
     
  14. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #14
    Personally, I would say use the built in appletv preset and call it a day.
     
  15. Dr. Dastardly thread starter macrumors 65816

    Dr. Dastardly

    Joined:
    Jun 26, 2004
    Location:
    I live in a giant bucket!
    #15
    Well I finally figured out what the problem was. I was encoding everything in .mp4 or .m4v for time sake. As a test I encoded the first chapter of a movie using .mp4 .m4v and h.264 and the only one that crossed over to the Apple TV was h.264. Then I encoded the entire movie (10 hours later on 1.5 Ghz G4) to h.264 and it seems to cross over fine.
     

Share This Page