Just About ready To Chuck FCPX

Discussion in 'Digital Video' started by New2012MacForMe, Jan 15, 2013.

  1. New2012MacForMe macrumors member

    Dec 26, 2012
    Ok, I think I've officially had it with this program. One problem after another. $3K for a new computer and another $300 for FCPX and I still wish I was editing on my 6 year old HP with Pinnacle Ultimate Studio.....

    Latest problem is that FCPX freezes and computer needs a hard re-boot everytime I try to use titles in the application. Anyone know how to solve this? It happens either with optimized or proxy files. There is no background tasks going on. I simply move the title over to the timeline, double-click on it and it freezes. Next time I opened FCPX, I had a few seconds before it froze again. On the third try, I got smart and used those few seconds to delete the title - this time no freezing.

    This issue makes this program unuasable to me and I might have to ditch it soon for something else if I can't find a solution.

    Running on a late 2012 model iMac, i7, 16gb, 1tb fusion, 2gb video - editing on the fusion drive within the admin account.

  2. MacBoobsPro macrumors 603


    Jan 10, 2006
  3. DelisleBA.info macrumors member

    Apr 12, 2011
    Athens, OH
    Go raise hell.

    Your cpu is still under warranty, right? No way this should be happening. Call Apple or visit them.
  4. New2012MacForMe thread starter macrumors member

    Dec 26, 2012
    The problem seems to be happening to a number of people. I'll report it to Apple, but that won't solve my immediate problem. Not sure what the CPU has to do with it. The computer is fine, it's just the program that I am having problems with.

    Is there anyone else out there that has had this issue. If so, how'd you fix it?
  5. isethx macrumors regular

    Aug 14, 2008
    i actually have this exact same issue. no fix. i have to hard reboot.
  6. mBox macrumors 68020

    Jun 26, 2002
    What kind of files?
    When you work with Proxies are you at ProRes Lite or?
    I work with R3D converted to ProRes4444 at 4K resolution running on numerous MBP from retina to as old as 2009 Uni 17".
    Ive been through the beta days (earlier than 10.0.4) solid and nothing that bad occurs.
    I guess we will need more info as to what exactly is going on.

    Cause I can say the same about my Avid MC and Premiere Pro at work as far as crashing constantly goes :)
  7. New2012MacForMe thread starter macrumors member

    Dec 26, 2012

    Since I'm a little new to this, I'm not sure how to answer your Proxy/Prores question. In this particular case, I imported files directly from my video camera - they are in AVCHD in .m2ts format coming in. I import them with create proxy and optimized data selected. When I edit, it doesn't matter if I use proxy or optimized files, as soon as I import a title, I experience the freezing issue. When the freezing occurs, there are no background tasks running. Is there something else I need to check to answer your question? Thanks.
  8. mBox macrumors 68020

    Jun 26, 2002
    Yep the dreaded AVCHD format.
    That Ive heard about and have no experience since I dont have any cameras that output that.
    When you ingest you selected make proxy right?
    Do you let it finish first like say for every 30 min of video give it a few hours to convert?
    Ive heard many AVCHD users run into issues where they import and start working right away.
    Just cause Apple says you can I wouldnt listen.
    If you check their support site, you wont be alone with the AVCHD and .m2ts issues.
    If I ever run into this format, I would take it into MPEG STREAMCLIP first and convert to ProRes HQ.
    Then bring it into FCPX.
    Thats just me of course.
  9. New2012MacForMe thread starter macrumors member

    Dec 26, 2012
    Yes, I select make proxy. I didn't let it go as long as you indicated, but I made sure that all background tasks were done before continuing. I only brought in about and hour of video - background tasks, transcoding, etc was done in about 30 mins or so. I picked up Pavvtube converter. Maybe I can try converting the AVCHD (.m2ts) to Prores and then import that in rather than coming straight from the camera. I'll give that a try tonight.

    As far as the .m2ts format is concerned, I thought I got lucky being able to import it from the camera. If you simply pull the files off the camera and then try to import it from the hard drive, FCPX will not recognize it (file is greyed out).

    Thanks again. I'll report my findings later tonight.
  10. mBox macrumors 68020

    Jun 26, 2002
    Yea good luck with that.
    Thats the thing about any software is that unless everyone is using the same format and workflow as you, its hard to find answers on problems.
  11. New2012MacForMe thread starter macrumors member

    Dec 26, 2012
    Ok, here's what I found so far. It seems as though the program chokes during rendering on only one title (Pixie Dust). At least only one so far. No matter what format I use or how it's converted, the computer always locks up with that title during rendering. So far I have tried 5 or 6 other titles and they have all been fine. Could it possibly be a glitch just with that title? Also, converting the AVCHD file to any Prores format using Pavtube results in a slightly jittery video. So, no good doing that for me. The best solution was to continue to import straight from the camera and then share out the finished product in any format I choose. The only conversion I can do to the original AVCHD files that seems to produce a non-jittery file is mpeg-4. The quality is bit lower, but at least it doesn't jump. I'll stick with the camera import for now.

    Anyway, next step is to keep my eyes open when using different titles to see which ones lock up the system. Anyone have any ideas why it is just Pixie Dust and nothing else so far? Thanks.
  12. initialsBB macrumors 6502a

    Oct 18, 2010
    Just tried pixie dust title here and it crashed FCP X as soon as rendering started, but not the computer.
  13. mBox macrumors 68020

    Jun 26, 2002
    I am not familiar with PavTube never heard of that utility.
    Ill try the PixieDust effect on 3 different workstations today.
    Brb with results.
  14. throAU macrumors 603


    Feb 13, 2012
    Perth, Western Australia
    If you have to hard-reboot this is an OS X bug and should probably be reported to apple support so they can fix OS X.

    No application should be able to hard lock the OS.

    If the machine is locking up and needs to be powered off, then it is an operating system problem.

    FCPX may be triggering the problem, but the lockup is an OS X issue.

    Is your OS X fully patched to 10.8.2?
  15. New2012MacForMe thread starter macrumors member

    Dec 26, 2012
    Yup. First thing I did. Fully patched and updated.
  16. Imhotep397 macrumors 6502

    Jul 22, 2002
    Dude...stop torturing yourself already and and buy CS6. With the hardware investment you've already made it's a justifiable expense. If you're financially crunched you may want to look at HitFilm (I haven't used it, but have heard good things) or Lightworks (I've played with it and didn't like the palette approach to UI, but it was very suitable for what I was editing at the time.) No software is perfect, but I'm definitely a proponent of not slamming your head into that brick wall a couple of more times if there maybe an alternative.
  17. mBox macrumors 68020

    Jun 26, 2002
    LOL CS6?
    Isnt that a little much compared to FCPX?
    I teach both FCPX and Premiere Pro at local college.
    The only reason Id go with Premiere is if I had the Master/Production bundle in my system.
    Trust me they all have their stupid quirks.
    Just visit CreativeCow and witness it yourself.
  18. New2012MacForMe thread starter macrumors member

    Dec 26, 2012
    For the money I've sunk into FCPX, I'm sticking with it. As mentioned, so far it seems the only hard reboot issue is due to the Pixie Dust title and I can easily avoid that. Hopefully there are not others with similar problems. mBox, were you able to duplicate the issue?
  19. 4God macrumors 68020


    Apr 5, 2005
    My Mac
    I know you mentioned that it was one title that was the culprit but I still suspect that it's an OS issue that FCPX is triggering as mentioned in a previous post.
  20. daybreak macrumors 6502a

    Sep 4, 2009
    Having read this post and been following its progress it seems to me one thing lead to another problem.
    What i can gather "Pixie Dust Title" which i never hear off seems to be the culprit? Is this an After effect template?.
    When i started with FCP-X i did have a few crashes with titles. I put that down to Apple's new software. Later on a more advanced update i performed the same task and they worked fine.
    I maintain when working in FCP-X and a task makes you work crash leave it for a couple of days and try again.
    Not much help but i always say Why did it do that". Make a note and search all forms of internet on the subject.
    FCP-X is not the best application in the world but very powerful and time saving.:apple:
  21. mBox macrumors 68020

    Jun 26, 2002
    Tested on Mac Pro 10.8.2 by placing an R3D in Primary Storyline then applied the Pixie Dust Title as Secondary.
    Computer went into freeze mode.
    Force crash my Mac Pro and started up again.
    Now I cant replicate the problem.
    I hate that :p
    Tested on 10.7.4 Mac Pro (2 workstations) and it didnt crash.
    I would avoid that Title.
    Kinda a cheezy.


    That pretty well sums up almost every high-end app Ive ever had to use in this medium for both Mac, PC, Linux and Irix :)
  22. hltjr macrumors newbie

    May 19, 2009
    close to la, ca.

    FCX started going screwy on me after I purchased and started using a new external FW800 hard drive as of 01/01/13. Then it started requiring a reboot while working on events/projects that are on my internal hard drive. I blamed it on my older MBP, but it seems like it's happening with even newer machines. I'll continue to send the report(s) to Apple and hopefully all will be well soon. Thanks for sharing people.
  23. StevethePirate macrumors newbie

    Jan 11, 2013
  24. Zwhaler macrumors 604


    Jun 10, 2006
    Have you tried calling Apple?
  25. blackmoses macrumors member

    Mar 10, 2009
    Does this happen with any font? I would suggest running verification in Font Book and seeing if you have any bad fonts.

    Also, am I correct in assuming you're running FCPX 10.0.7 (latest version)?

Share This Page