Just bricked my iphone! help please : (

Discussion in 'iPhone Tips, Help and Troubleshooting' started by innocentegg, Jul 11, 2008.

  1. innocentegg Guest

    #1
    OK I updated my iPhone to the new 1.2 version today.

    But I don't have an o2 sim card so obviously it wanted me to activate it.

    I thought ZiPhone would jailbreak it for me so I used that and now but it didn't work, it just made my iPhone into a brick.

    And when I tried to get it back to the 1.1.4 version of the firmware I get this error:

    'The iPhone "iPhone" could not be restored. An unknown error occurred (20).'

    Any chance I can get it back working? Or have a messed with it so I can't now restore it? : (

    Any help would be very much appreciated!
     
  2. adamerr macrumors 6502a

    adamerr

    Joined:
    Jun 7, 2008
    #2
    btw. its software 2.0
    and, from what ive read, you shouldnt have used ZiPhone designed for earlier firmwares....

    so, who knows?
    my guess is its stuffed :(
    sorry
    BUT im ot an expert, so dont really listen to me that much
     
  3. lightningboot macrumors newbie

    Joined:
    Jul 11, 2008
    #3
    My cord came unplugged as my iphone was restoring with 2.0 the first time, and now I'm having the same problem as you. I downloaded 1.14 again, but then it sent my phone into recovery mode.

    Do you have AIM by any chance?
     
  4. innocentegg thread starter Guest

  5. innocentegg thread starter Guest

    #5
    any way of doing a COMPLETE restore without using itunes? that could work...
     
  6. lightningboot macrumors newbie

    Joined:
    Jul 11, 2008
  7. rball1979 macrumors regular

    Joined:
    Jun 6, 2008
    #7
    Even if you successfully upgrade to 2.0 a non iphone sim card won't work as it will re lock the SIM
     
  8. innocentegg thread starter Guest

    #8
    I know that, but I thought (stupidly) that ZiPhone would work with the new 2.0 <.<

    Trying that process with the iTunes 7.5, will tell you how I got on.
     
  9. innocentegg thread starter Guest

    #9
    Ok first thing, NO ERROR MESSAGE :D

    fingers crossed that the process will work!
     
  10. lightningboot macrumors newbie

    Joined:
    Jul 11, 2008
    #10
    wouldnt work for me because the library was synced with another version of itunes or something.

    >_<

    I got the update though from apple on 2.0, and its downloading now. I guess well see how that turns out eh?
     
  11. rball1979 macrumors regular

    Joined:
    Jun 6, 2008
    #11
    The Dev Team have cracked 2.0 but, to my knowledge, theres no public software for us to use yet!
     
  12. innocentegg thread starter Guest

    #12
    I HAVE GOT IT BACK :D:D

    Well it says emergency only but its the default screen none the less! Ok this is how I did it so far:

    - Put it into DFU mode, then restored it in iTunes 7.5 and got error 1015, which is good : ), Ran iBrickr and screen turned green : (
    - Restored it again using iTunes 7.5 and got the error again (1015)
    - Ran iBrickr again and the screen red!! :D

    It works now! I just have to Pwn it and hopefully back to new! : )
     
  13. innocentegg thread starter Guest

    #13
    I rebooted my mac into windows where I didn't even have iTunes installed (lucky ) and then I just installed iTunes 7.5 from a website, I'm going back into OS X to put all my data back onto the iPhone.

    I like windows now :D
     
  14. innocentegg thread starter Guest

    #14
    right, I used winpwn to unlock the iphone and suddenly it doesn't even want to turn on!

    So I had to put it in DFU mode again, and going to have to do the whole process again, but this time; i'm using ZiPhone as it works!! (I hope)
     

Share This Page