Just got a 3870... not any faster?!?

Discussion in 'Mac Pro' started by matt321, Dec 22, 2008.

  1. matt321 macrumors member

    Joined:
    Oct 27, 2007
    #1
    Ok, I just got an Ati 3870 since the fan was going out on my 1900xt.

    I installed the new drivers, restarted, and then shutdown the computer to make the swap.

    I'm using 10.5.6 and in WoW, using the *exact* same settings as before, it gets about 5 FPS less than the 1900xt (1900 x 1200, windowed mode, VSync with triple buff, 2xAA, set to Highest Detail)


    I thought maybe it was something to do with 10.5.6 so I installed the update again via the combo updater. Same results.


    Any ideas???


    Thanks!
     
  2. ventro macrumors 6502a

    Joined:
    Sep 23, 2006
    #2
    Turn off Vsync? That basically keeps your FPS constant at 30 or 60 fps.
     
  3. netkas macrumors 65816

    Joined:
    Oct 2, 2007
    #3
    3870 is a more powerfull than 1900 when it comes to shaders

    but, WoW isnt using shaders(or not using it much).

    meh, i tested quake3 in snow leo, with 4850, time demo gave me just about 78fps
     
  4. matt321 thread starter macrumors member

    Joined:
    Oct 27, 2007
    #4
    Yeah when I turn off VSync it goes faster but choppier. I guess I was expecting more but....

    Any other 3870 owners see similar results?
     
  5. smogsy macrumors 6502a

    Joined:
    Jan 8, 2008
    #5
    FPS on WoW is limited by the servers mostly, not just your PC unlike most pc games. hey google it if you don't believe me

    my mate had quad-core and GTX280 and he still had very low fps in places, its all down to the server your on & how busy the server is.
     
  6. matt321 thread starter macrumors member

    Joined:
    Oct 27, 2007
    #6
    @smogsy: That makes sense about the servers as other things seem to be faster (Expose with 20+ windows does not shutter any more.)
     

Share This Page