Just got a 'usb device drawing too much power' message. wtf??

Discussion in 'MacBook' started by Wie Gehts, Jul 7, 2009.

  1. Wie Gehts macrumors 6502

    Joined:
    Mar 22, 2007
    #1
    In the nearly 2 years I've had my macbook, I just got a message that said one of my usb devices was drawing too much power and will be disconnected from its hub.

    the problem is....i do have a hub, but I don't have it connected to my computer.
    I have one ext usb hd going directly into one port on my macbook...and an ext dvd burner going directly into the other...and they both only operate with their own power supplies!

    Can anybody tell me what the heck this might mean?

    Thanks
     
  2. iShater macrumors 604

    iShater

    Joined:
    Aug 13, 2002
    Location:
    Chicagoland
    #2
    Make sure the power supplies for the externals are working properly.
     
  3. u49aa2 macrumors 6502a

    u49aa2

    Joined:
    Nov 3, 2008
    Location:
    Between Heaven and Hell
    #3
    Just restart your laptop, and it should disappear. If it comes back in the future run diagnostic with TechTool that came with your apple care to see if there is a problem with your usbs.

    It could also mean that your having a problem with your LogicBoard.
     
  4. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #4
    Thanks....yes, I'll run the techtool diagnostic. The macbbok's been runnung great so far... I hope there isn't any problems.

    Although.....the other day I had some glitch that when I had a window open on an ext hd, my keyboard wasn't operating properly within it.

    For ex...if I clicked on the name of a folder and pressed 'enter' to highlight it and type in a new name, pressing 'enter' wouldn't do anything....or if I created a new folder and went to type in the name, it wouldn't accept my keystrokes.

    But I did a PRAM zap and its been fine so far. Sheee, I hope nothings failing. :(
     
  5. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #5
    I ran techtool (deluxe) and everything passed. but can I have confidence that techtool diagnostics would find anything?

    When I got this message, I had a usb hd and dvd burner connected. So even though it said it would disconnect a device, apparently it wasn't the usb hd cause I got still use it. Maybe the dvd burner...well I wouldn't know that unless I tried to use it or maybe see if Toast seen it. Its possible the cable I used is bad...its one that comes in the package with whatever device I bought.
     
  6. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #6
    hmmmm everything was fine till I connected the ext dvd burner this morning. I haven't used it in several weeks. I wanted to copy a dvd I got form the library that I didn't see yet and is due back.

    When I first loaded it, DVD player said it was a format that was unplayable which is strange.
    Then I changed cables and it worked. But then as I was copying it I got a device removal message, the disc unmounted and the ripper program bailed.

    I'm suspecting its the burner. I'm hoping its that and not my computer.
    I'll go back to my usual ext connections which been working fine and not use the burner and see if I get any more messages.
     

Share This Page