Just got an iphone and need help!

Discussion in 'iPhone' started by babond, Sep 5, 2007.

  1. babond macrumors member

    Joined:
    Sep 5, 2007
    #1
    So I was stoked to get my iphone today and I get it home to activate it and realized it required OSX 10.4 and im using OSX 10.3.9! So I got a few questions. My friend has a brand new macbook pro so im going to activate it using his cpu and whenever I need songs I'll also use his cpu. I figure I can charge it through the wall outlet for the time being and if I really need new songs or applications I can use his computer. Other than stuff like that do I really need a computer handy with 10.4? Also I guess I'd like to upgrade to 10.4 but hate the idea of spending $129. I will if I must but what would be the best way to get 10.4 without buying it from apple? errr my parade has been rained on hardcore today!!!
     
  2. Malamutt macrumors regular

    Joined:
    Jul 10, 2007
    #2
    First the requirments for iTunes is 10.3.9 so didn't realize you can't activate your phone. Never spotted that in the requirements till you said something. Mac OS X 10.4.10 or later required for iPhone

    Second. Buy a used copy from someone. Try craigslist or ebay. Or wait 2 months and see if the price goes down on 10.5 when it comes out :)

    :apple:Malamutt

    My new answer to anything Apple prices. Wait two months. The price may change.
     
  3. Sean7512 macrumors 6502a

    Joined:
    Jun 8, 2005
    #3
    If you are a college student, you can get 10.4 for only $70 which is a good deal. However, with 10.5 coming next month, you're better off waiting until then. Depending on your if your computer can handle 10.5 or not, I'd imagine that 10.4 will be discounted once 10.5 rolls around...
     
  4. babond thread starter macrumors member

    Joined:
    Sep 5, 2007
    #4
    i guess i might just buy it from apple. im kind of worried about how it will run on my cpu. my processor is 933mhz and my memory is 256. you think that will run 10.4 ok? also is it fairly easy to install over my current os?
     
  5. drater macrumors 6502a

    drater

    Joined:
    Oct 6, 2005
    Location:
    Boston, MA
    #5
    give me $200 and I'll tell you everything you need to know...jk. I don't know sh*t
     
  6. suneohair macrumors 68020

    suneohair

    Joined:
    Aug 27, 2006
    #6
    Well the CPU is fine. The memory is... well, lacking a bit. Tiger will run.. but it won't be pretty. What system do you have? I may have some RAM I can send you if it is a G4 Tower.

    It should install just fine. Make sure you do a backup just in case.
     
  7. KittyToy macrumors 6502

    KittyToy

    Joined:
    Sep 6, 2007
    Location:
    Davenport
    #7
    i have no idea what you people are talking about i don't own a mac , i have a toshiba with windows vista and i had no issue with synching my iphone or anything else. i didn't have to activate it because they did that for me at AT&T when i bought the phone!
     

Share This Page