Just installed Samsung 840 EVO SSD - 2 Questions

Discussion in 'MacBook Pro' started by scjfly, Aug 21, 2014.

  1. scjfly macrumors newbie

    Joined:
    Oct 20, 2010
    #1
    Hey Guys,

    I just installed the 1TB 840 EVO in my late 2011 macbook pro. A huge improvement.

    I have a couple of questions though. First, during install I removed the 4 t6 mounting screws from the original HD and tried installing them into the SSD but they were a too small in diameter to thread in correctly and also appear to be a little too long. Anyone else ran into this? Where can I get the appropriate screws?

    Also, I keep reading about needing to install trim enabler. Can anyone point me in the right direction? I'm rather ignorant to the subject. I'm running the latest version of Mavericks.

    Thanks.
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    I didn't run into this issue with my 2009 MBP and my Crucial M4. I thought the screw sizes were pretty standardized, but maybe the newer models use different screws.

    http://www.cindori.org/software/trimenabler/
     
  3. awests macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    Bay Area, CA
    #3
    I just installed a Crucial MX100 into my 2011 MBP, screws fit fine. That is odd they don't fit.

    As posted before, download and enable TRIM Enabler. Just be careful when updating to 10.10, as there are issues with 3rd party SSD's and TRIM support.
     

Share This Page