Just installed SL and Mail won't remember my Comcast POP email password.

Discussion in 'macOS' started by Imola Ghost, Aug 28, 2009.

  1. Imola Ghost macrumors 65816

    Joined:
    Mar 21, 2009
    #1
    I first synced it via Mobile Me and when the password wouldn't save, I deleted the comcast email account and started fresh but it still keeps asking for password. I know I have the correct password inserted because I went to the web site email and logged in with the same password I'm using in Mail.

    Any ideas?
     
  2. JWSandi macrumors regular

    Joined:
    Jul 19, 2008
    Location:
    Trashville, TN.
    #2
    Yeah, I'm unable to send emails using Apple Mail after installing Snow Leopard
    ...
     
  3. Imola Ghost thread starter macrumors 65816

    Joined:
    Mar 21, 2009
    #3
    I am able to send/receive email thru Mobile Me and my Gmail account but nothing in Comcast.
     
  4. rxl125 macrumors regular

    Joined:
    Apr 15, 2006
    #4
    is there a fix for this? I can't send mail either.
     
  5. JWSandi macrumors regular

    Joined:
    Jul 19, 2008
    Location:
    Trashville, TN.
    #5
    I got tired of tinkering with it and just downloaded Thunderbird, it works fine.

    So the problem is not so much Comcast as it is/was Snow Leopard.

    Apple will most likely address it in any forthcoming patch/update.
     
  6. vansouza macrumors 68000

    vansouza

    Joined:
    Mar 28, 2006
    Location:
    West Plains, MO USA Earth
    #6
    In Accounts you need to edit your smtp settings... then click on advanced and choose any of the 3 digit numbers and remove the 25 as the port number.
     
  7. Peace macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #7
    It's not the mail.app.It's comcast's mail servers. Happens all the time in both SL and Windows.
     
  8. rxl125 macrumors regular

    Joined:
    Apr 15, 2006
    #8
    STOP!!! it's snow leopard...
     
  9. Peace macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #9
    Tell that to the Windows install I have then.;)
     
  10. cbadland macrumors newbie

    Joined:
    Sep 25, 2009
    #10
    Just updated Snow Leopard 10.6.1
    Now our comcast email account works with Apple Mail.
     
  11. lannister80 macrumors 6502

    lannister80

    Joined:
    Apr 7, 2009
    Location:
    Chicagoland
    #11
    Comcast's mail servers are terrible. I get "rejected password" issues all the time, then they magically fix themselves without me putting in a new password. Goddamn Comcast.
     
  12. aipmto macrumors newbie

    Joined:
    Oct 28, 2009
    #12
    Making MacMail work on Comcast

    I had same issue on my Mac Mail with three separate Comcast email accounts. My 5 other email accounts all work fine.

    Try this: Go to Mail Preferences - Accounts - (select your Comcast account) - Advanced tab. Now change your Port to 995. Comcast told me to change it to 587, but that didn't work. I called Comcast two more times and got someone who said to change it to 995.

    I don't believe this would make a difference, but (for the record) I have the SSL box checked and am using Password Authentication.

    I will tell you that it took about 10 minutes before my Comcast mail came in on one of my accounts and only about a minute for the two other lesser-used accounts.

    Good luck! :rolleyes:
     
  13. ssmed macrumors 6502

    ssmed

    Joined:
    Sep 28, 2009
    Location:
    UK
    #13
    Try fixing your keychain

    I would delete the keychain entry for this password and run Keychain First Aid and then see if the password sticks. The transition for the keychain entries when upgrading to 10.6 does seem as smooth as it should be, based on 4 installs.

    Hope this helps
     

Share This Page