Just totally screwed up my SSD. Help!

Discussion in 'OS X Mountain Lion (10.8)' started by filmbuff, Nov 10, 2013.

  1. filmbuff macrumors 6502a

    filmbuff

    Joined:
    Jan 5, 2011
    #1
    I'm an idiot. This is what happens when I stay up too late and try to 'fix' my computer. Here's what happened:

    I wanted to make my bootcamp partition bigger. I used disk utility to shrink my main OSX partition. In Windows, disk manager showed the free space I had created, but I couldn't expand the partition. I thought this might be because the free space was still formatted as Mac OS Extended-Journaled. So I got the bright idea to reformat that free space partition in OSX as MS-DOS FAT.

    When I did that I got a message that Bootcamp may not work, but I decided to take my chances. Upon restarting, Windows 7 was gone from the startup menu and it looks like I 'lost' Bootcamp. (the Bootcamp partition itself is still visible in disk utility and I didn't touch it).

    After that I thought maybe I could undo what I had done, so I erased the new partition and tried to expand my main OSX partition back to fill in the free space. It didn't work (no error message). So now I'm left with an OSX partition, free space that I can't use, and a Bootcamp partition that I can't boot from.

    Before I make the situation worse, I need some suggestions on what do do here. I want to keep my Bootcamp partition if at all possible because I don't have the disk to reinstall Windows on hand.
     
  2. 53kyle macrumors 65816

    53kyle

    Joined:
    Mar 27, 2012
    Location:
    Sebastopol, CA
    #2
  3. filmbuff thread starter macrumors 6502a

    filmbuff

    Joined:
    Jan 5, 2011
    #3
    It worked. Thanks a bunch!

    Now the only issue left is that I have 3 partitions on my SSD. If I delete the little one I have blank space, but when I expand my main OSX partition to fill that space nothing happens. After disk util says it is done partitioning the blank space is still there and my available space stays the same.
     

Share This Page