JVC Everio GZ-MG330 and iMovie ????????

Discussion in 'Mac Accessories' started by imac abuser, Jun 5, 2008.

  1. imac abuser macrumors 6502a

    imac abuser

    Joined:
    Mar 1, 2004
    #1
    Hello,
    I just bought a JVC Everio GZ-MG330 HDD camcorder. Before I open it I'm wondering if it's going to be simple to use with my set up. I have a Macbook Intel Core 2 Duo, and I'm using iMovie '08 (don't get me started on iMovie '08 I think it sucks).

    If I shoot video, and plug the camcorder in via the USB will the HD show up on my desktop, and iMovie '08 recognize, and import it like I would hope for or am I going to have to jump through hoops to get it in iMovie '08?

    I just kinda want to know before I open the dang thing so Best Buy doesn't charge me 15% if I want to return it.

    I found this video on You Tube which makes it look simple as pie, but then I read the hells people are going through all over the place.

    http://www.youtube.com/watch?v=V-Vx5CyYYZo

    Thanks for your help!
     
  2. Chase R macrumors 65816

    Chase R

    Joined:
    May 8, 2008
    Location:
    PDX
    #2
    I know I'm bringing this thread back from the dead but did this camera work out for you using iMovie '08? This is the camera that I have been looking at getting.
     
  3. kokomongx1 macrumors newbie

    Joined:
    Oct 31, 2008
    Location:
    SO CAL
    #3
    Having trouble transfering files

    hello,

    i recently purchased my first camcorder and have been recording but having a hard time transfering the vids to my mac. the problem is that the movies goes to my hardrive in a .mod (i don't know if this is supposed to be the right file type), but then when i drag the clip into my imovies, a pop-up comes up saying that the file is incorrect.


    would this problem be occuring because im outdated (i'm using tiger 10.4.11) and that the camcorder i just purchased is running on a a more recent software ???

    PLEASE CAN SOMEONE RESPOND TO MY THREAD
    HELP VERY MUCH APPRECIATED

    P.S - IM A SUPER TECH NOOB :(
     
  4. imac abuser thread starter macrumors 6502a

    imac abuser

    Joined:
    Mar 1, 2004
    #4
    I took my Everio back I gave up... Sony's always seem to work well not to mention the iLife 08 iMovie sucks better off using the old version
     
  5. soLoredd macrumors 6502a

    Joined:
    Mar 12, 2007
    Location:
    California
    #5
    I use an Everio with iMovie 08 and it works fine. I've never had a problem, although I've read of people having headaches with the Everio. The thing is, I received the Everio when my dad passed away, so I can't complain. The clips import fine, it's easy to use for a basic camcorder.

    I do plan on getting a Canon HD camcorder in the spring though. The Everio won't be enough when the baby is born.
     
  6. imac abuser thread starter macrumors 6502a

    imac abuser

    Joined:
    Mar 1, 2004
    #6
    I guess I haven't taken the time to learn iMovie'08 so just using it on the fly i didn't like it.
     
  7. Frederic macrumors newbie

    Joined:
    Nov 27, 2008
    #7
    JVC Everio GZ-MG330 works fine with iMovie '08

    JVC Everio GZ-MG330 camera works fine to import movies in iMovie '08 on iMac (Mac OS X - 10.4). See this page for list of cameras supported by iMovie '08: http://support.apple.com/kb/HT1014

    Make sure that you open iMovie '08 AFTER you have connected your JVC camera to your iMac (via USB cable), and activated the Playback on PC setting on the camera. If iMovie '08 is already open when i connect my camera to my iMac, then for me, iMovie does not recognize the format of the videos on my JVC Everio, even though iPhoto start fine and imports any photos i might have on my camera. So first connect your JVC camera to your iMac, second start iMovie, then iMovie will automatically try to import videos on your JVC camera.

    I don't think this makes a difference with iMovie '08, but FYI i upgraded my version of QuickTime to QuickTime Pro, and added MPEG Streamclip 1.9.2 from http://www.squared5.com/ - (I forget if i had to pay something for it; maybe i paid $20 for it...). This allows my QuickTime viewer to play videos coming from my JVC camera. It works great!

    In the old days of iMovie '06, one could use FFmpegX (http://www.ffmpegx.com/) to import .MOD files (the MPEG2 format used by JVC Everio GZ-MG330). This software is no longer required with iMovie '08. iMovie '08 can import directly videos in .MOD format.
     
  8. The Guardian macrumors newbie

    Joined:
    Dec 4, 2008
    #8
    This worked great for me, THANKS!
     
  9. aaronmaiden macrumors newbie

    Joined:
    Jan 18, 2009
    #9
    Help!!

    I bought the GZ-MG330 last week. I think it's a great camera for the price, but, I'm still having trouble with using it with my Macbook after reading this thread and dozens like it over the past week.

    I have a two year old Macbook 2.26Ghz Intel Duo with 1GB ram. I'm running 10.4.11. I originally had iLife 06 with iMovie HD. Once I bought the camera, I kept having the same trouble everyone else does, so, I bought iLife 08 thinking iMovie 08 would recognize these MOD files right away. No luck.

    The only way I've been able to use the files on my Mac are to convert the files using an application called iSquint. I don't like the resolution after converting the files, so I'm not really into this option.

    This is ALL new to me. Just trying to figure out how to easily use my camcorder with iMovie without having to jump through hoops. What am I doing wrong here?
     
  10. WPB2 macrumors 6502a

    WPB2

    Joined:
    Jul 1, 2008
    Location:
    Southeast, LA
    #10
    Thats the same setup I use, and it works fine for me. I just loaded my video I shot for new years, and worked like a charm.
     
  11. aaronmaiden macrumors newbie

    Joined:
    Jan 18, 2009
    #11
    i watched a video on youtube where the guy just plugged in the camera, started iMovie08 and it recognized the videos right away. it's still showing the .MOV files as a blank page for me and my Mac doesn't know what they are. is there anything i could be doing wrong?
     
  12. aaronmaiden macrumors newbie

    Joined:
    Jan 18, 2009
    #12
    sorry, i meant .MOD files, but, i'm sure you knew what i meant.
     
  13. HiD macrumors newbie

    Joined:
    Apr 1, 2009
    #13
  14. xsasuke macrumors newbie

    Joined:
    May 14, 2011
    #14
    Helpp

    Makes no sense to me I have a ton of footage from my jvc enverio Gz-Mg330 on my macbook pro
    because it was compatible and worked fine.
    plugged in usb, put playback on pc, nd bam its all in imovie...
    but now that its been a couple of weeks later my mac decides all of a sudden it doesnt want to work anymore and it wont even say that a camera is plugged in.

    Please, I desperately need help with this
     

Share This Page