k key not working

Discussion in 'macOS' started by slh1313, May 13, 2010.

  1. slh1313 macrumors newbie

    Joined:
    May 13, 2010
    #1
    Whenever I hit my "k" key I get the following symbol ˚. If I hit shift with it I get . Why is this stuck on, and how do I undo it? I am not hitting the control, option, or command button with the key. I am sick of having to copy and paste all my k's. Please help! -Also, when I hit my left side option key alone it also gives me the ˚, but the option key on the right side behaves normally. I am using a laptop.
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Sounds like your "alt" key is having problems. Maybe press alt a couple of times to see if it releases?
     
  3. slh1313 thread starter macrumors newbie

    Joined:
    May 13, 2010
    #3
    I tried that, and no other keys are having a problem. I've messed with the function, control, option (alt), and command keys and nothing seems to help.
     
  4. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    What happens when you hit option L or option J?
     
  5. slh1313 thread starter macrumors newbie

    Joined:
    May 13, 2010
    #6
    I have tried restarting, no change. When I hit my option key with other letter keys it gives me a symbol, but the letter keys work fine on their own except the k. Also I have discovered that my k is acting like my option key, meaning when I hit the k and another letter is quick succession, I get a symbol.
     

Share This Page