iPad Keep getting error when trying to install\remove cydia tweaks

Discussion in 'Jailbreaks and iOS Hacks' started by shenan1982, Jun 15, 2014.

  1. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #1
    So I keep trying to install\remove cydia tweaks, and whenever I do, I keep getting this Iconoclasm error, like it's also trying to install it... but it's already installed and working fine.

    - I have tried uninstalling Iconoclasm, but it won't uninstall because I keep getting the same error when uninstalling it.

    - When I try to add a new tweak, it lets me, but it still gives me the red Iconoclasm error text.

    - When I try to REMOVE a tweak it acts like it completes it, but it doesn't, and I also get the iconoclasm error text.

    Anyone know how to resolve? I've tried going into safe mode and removing iconoclasm, without success. Not sure how to otherwise manually remove the tweak to be able to reinstall it, so I seem to be stuck here.

    I attached the screen shot showing how when I try to remove any tweak, it also seems to think it is going to try and install iconoclasm. And I attached a screen shot of the error.


    EDIT: I notice it references xSellize in the error. I think it's because a while back I had downloaded it from xsellize, but then purchased it from ModMyI... so there seems to be something conflicting... now that I see that, it must be the issue, I just don't know how to get to resolution. Thanks!
     

    Attached Files:

  2. Syndicate0017 macrumors 6502

    Joined:
    May 3, 2013
    #2
    Remove xsellize from your sources and then uninstall iconoclasm.
     
  3. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #3
    This is one of the issues may occuring when installing tweaks from others than the original repos.
    To prevent from such issues remove all pirated tweaks as well as the pirate repos.
    To solve your issue with Iconoclasm remove the xSellize tweak (if not already done) and then open iFile, go to /Library/Iconoclasm/Layouts/ folder and manually delete the old 4x4.plist. Afterwards install Iconoclasm from the original repo.
     
  4. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #4
    Can't remove the xsellize security tweak (or any other tweaks) as stated above because it keeps first trying to install and erroring out on installing iconoclasm (even though it's not installed)...
     

Share This Page