keep getting error when trying to make cmus from source: file was built for i386 whic

Discussion in 'macOS' started by mandorle, Jul 1, 2012.

  1. mandorle macrumors newbie

    Joined:
    Jul 1, 2012
    #1
    hi

    i'm on 10.6.8

    today i tried to build cmus player from source. it hasn't gone well. i'm not quite a computer beginner but i'm no expert.

    macports got all wonky on me after i recently updated it. then i tried homebrew which caused havoc in the /usr/local/ folder and paths and manpaths so i got rid of that. but i love cmus. it's my favorite music player. on top of it being light and fast, it has the best sound. i can't live without it.

    i compiled all the codecs necessary for it to work but when i use the make command i get this

    i get lots of ld:warning:

    the last being:
    Code:
     
    ld: warning: in xmalloc.o, file was built for i386 which is not the architecture being linked (x86_64)
    Undefined symbols:
      "_main", referenced from:
          start in crt1.10.6.o
    ld: symbol(s) not found
    collect2: ld returned 1 exit status
    make: *** [cmus] Error 1 
    
    
    i tried these commands to remedy the situation

    env CFLAGS=-m32 ./configure and CFLAGS=-m32 ./configure.

    neither worked.

    any ideas on how to successfully compile cmus?
     
  2. mandorle thread starter macrumors newbie

    Joined:
    Jul 1, 2012
    #2
    i installed homebrew to the home directory and i have my beloved cmus without messing with /usr/local/ permissions.
     

Share This Page