Keep getting wife's text messages

Discussion in 'iPhone' started by martosprint, Sep 6, 2015.

  1. martosprint macrumors 6502

    Joined:
    Jun 1, 2010
    Location:
    Florida
    #1
    My wife and I both have iPhones 6+ and a 5S, and we both have different email and telephone numbers. When my son and grandson text my wife using her addresses the messages also comes in to my phone. Granted that my wife and I both share the same Apple ID etc, but that wouldn't be the reason. Now my son and grandson both have the iPhone 6+. Why would this issue be happening? I may not get back into the forum until perhaps Monday to check.
    thanks for a reply...
     
  2. imaginex20 macrumors 65816

    imaginex20

    Joined:
    Jun 17, 2009
    #2
    Go to Settings - Messages and check to see if your email addresses are only checked.

    I personally would sign out of my appleId here if it was signed in. This ensures that I will only send and receive messages to and from my phone number
     
  3. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #3
    It is due to both you and your wife having the same Apple ID.
     
  4. Merkie macrumors 68020

    Joined:
    Oct 23, 2008
    #4
    Why do you share the same Apple ID? This causes problems like this. Don't share Apple IDs.
     
  5. AFEPPL macrumors 68030

    AFEPPL

    Joined:
    Sep 30, 2014
    Location:
    England
    #5
    I share my id with around 10 different device for the family. Why - because from an iTunes point of view it was the best way to have purchases shared over many devices.

    All you do on each device is set the imsg id and email id so nothing cross pollinates..
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Settings - Messages,send&Receive, select your phone number only.
    Remove the Apple ID for imessages.
     
  7. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #7
    My wife and I share one Apple ID and we don't get each others messages. Which emails and phone numbers are received on which device is completely controllable in Settings -> Messages -> Send and Receive.
     
  8. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #8
    You can use separate accounts for iTunes and the App Store than for iMessage and the rest of iCloud.
     
  9. martosprint, Sep 6, 2015
    Last edited by a moderator: Sep 23, 2015

    martosprint thread starter macrumors 6502

    Joined:
    Jun 1, 2010
    Location:
    Florida
    #9
    Okay thanks for all the replies. No it wasn't due to the fact that we share the same Apple ID. The answer was in Settings -> Messages -> Send and Receive. All I had to do was uncheck my wife's phone number in that setting on my phone. This had been bugging me for quite awhile and now it's fixed. My son is at the house now and just sent my wife a text and she got it and I didn't. What a relief! Thanks for all the replies.
     
  10. nigameash macrumors 6502

    Joined:
    Dec 6, 2008
    Location:
    Space: The Final Frontier
    #11
    Unless you're sharing icloud accounts for the icloud backup storage (you pay for having more than the default 5gb free storage), there's no reason to be using the same icloud account. It's better to use individual icloud accounts and share the itunes account only. With family sharing, this too can be avoided.
     
  11. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #12
    In what way better? We have shared one Apple ID and iTunes account between us for years and haven't come across a problem yet. All other options make an already complicated situation more complicated, and limited. EG would we be able to have a single shared Photos library across all our devices if she had her own Apple ID? There may be a way but not as simple as being on one ID.
     
  12. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #13
    Technically that is because you are sharing the same Apple ID. The devices are linked to that account, so if I have 2 iPhones (work and personal) you can get all your messages, FaceTime, etc etc if you so choose.

    A lot of people may have a problem with that for privacy reasons. And don't think shady stuff but for example I might not want my wife to see my business messages so she doesn't worry about things or something.

    In my experience I found separate AppleID's to be better to avoid the confusion of what you experienced. But I'm glad you got it to do what you needed it to do.
     
  13. supersalo macrumors 6502

    supersalo

    Joined:
    May 14, 2010
    #14
    It *is* because you're using the same Apple ID in Settings -> iMessage.

    What you've done is disabled the ability to receive iMessages that are addressed to the phone number on your wife's phone by unchecking the phone number in the 'You can be reached by iMessage at' section.

    This means that all messages sent to her phone number will be SMS (green). You might want to check if your phone's plan includes unlimited text messages. If it doesn't, it can get costly.

    Messages sent to one of the email addresses listed in the 'You can be reached by iMessage at' section will be iMessages. Anything sent to her phone number will be SMS.
     
  14. Mike Boreham, Sep 8, 2015
    Last edited: Sep 8, 2015

    Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #15

    This is simply not true. As I said, my wife and I have one Apple ID and can chose independently on each device what messages are received on that device. Both our phones receive iMessages and SMS messages.

    My iPhone is set to receive messages from my number and our iCloud email address.
    Her phone is set to receive from her number and the iCloud address.
    Our computer is set to receive from from both phone numbers and the iCloud address.

    And that is how it works. Both our phones receive iMessages when the message is an iMessage (blue) and SMS when the message is not (green). The computer cannot receive SMS so only gets iMessages but gets all iMessages which are sent to either phone number or the email.

    EDIT, thanks to this thread, I checked up on SMS going to the Mac, and discovered the Text Message Forwarding in Settings -> Messages -> Text Message Forwarding. So looks like I can get SMS on the Mac. Not that we use the computer much for any kind of messaging.
     
  15. supersalo macrumors 6502

    supersalo

    Joined:
    May 14, 2010
    #16
    You can believe what you want, but it is true. Any Google search will show that iMessage uses your iCloud ID.

    For example: https://support.apple.com/en-us/HT201349
     
  16. JaySoul macrumors 68020

    JaySoul

    Joined:
    Jan 30, 2008
    #17
    I keep getting text messages from my wife too. Sucks.
     
  17. wolfedude88 macrumors regular

    wolfedude88

    Joined:
    Feb 21, 2013
    Location:
    Indiana
    #18

    This is right and wrong.

    It is definitely because of sharing of the Apple IDs. But as he already figured out you can select which devices receive messages from whatever number or email address attached to it.

    So on his phone he just unchecks her number and he won't receive any messages that are being sent to her number.

    On her phone, she does the same thing. She unchecks his number and as long as her number is checked on her device, both the husband and wife can receive iMessages on their own device.

    Still the problem was because of sharing the Apple ID but can be easily fixed as already stated or getting two separate IDs.
     
  18. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #19
    Of course iMessage uses my iCloud ID....I didn't say anything different. All I said is that different devices using the same Apple ID can be set independently to receive or not receive messages from the different phone numbers. So you don't need to see your wife texts messages and vice-versa.
     
  19. tallcool1 macrumors newbie

    tallcool1

    Joined:
    Sep 22, 2015
    Location:
    Charleston, WV
    #20
    Go to Settings/Messages & see if the iMessage is on. If it is-- you have to turn OFF her/your Apple ID and sign out. Then, sign in with your/her Apple ID-- depending upon which messages you want on that phone. You need separate Apple accounts.
     
  20. darknyt macrumors 6502a

    Joined:
    Sep 17, 2009
    #21
    Oh - there are reasons.

    There are reasons. :D
     
  21. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #22
    tallcool1, please read the rest of the thread. You do not need separate Apple IDs to avoid getting each others SMS and iMessages.
     
  22. plasticmoz macrumors regular

    Joined:
    Sep 15, 2007
  23. bueller1 macrumors 6502

    Joined:
    Jun 13, 2012
    #24
    At least you'll know if she's randomly paying your neighbor a visit ....
     
  24. darknyt macrumors 6502a

    Joined:
    Sep 17, 2009
    #25
    Kinda. Sorta. Maybe.

    For me, not really.
     

Share This Page